German Number Formats in Kibana


#1

According to a former post here I would like to know how to achieve a German number format like 12.345,67 for general settings using Kibana 6.4.1.
I saw the git hub link to issue https://github.com/elastic/kibana/issues/9228 which is marked as solved but I'm still not able to manage it.
Any help is highly appreciated.


(Larry Gregory) #2

Hi @BicaLuv,

Can you elaborate a bit more on what you're seeing or not seeing?

When I configure my locale in advanced settings:

Then my dashboard seems to update with the correct settings:


#3

Thank you Larry for your response.
Try a pie chart with a count over 1,000 and locale set to "de". On my system it displays "1 000" but the correct visualization would be "1.000".

BTW 1: In our screenshot of the map, the date in the table is not shown in German notation.

BTW 2: What happens when you click Rest to Default in the advanced settings page? On my system it defaults to be-nl. Strange.


(Larry Gregory) #4

Ah I see now, thanks for clarifying!

Kibana uses a library called numeraljs for localizing number formats. That library has an open issue for this very problem. If we can get them to fix the issue, then Kibana can update the version we use to incorporate the fix. In the meantime, I'd recommend voting for that issue on numeraljs's repository: https://github.com/adamwdraper/Numeral-js/issues/533


#5

Not sure if this will get fixed, because it is stated to be a duplicate of an issue dated Feb 2014.
Maybe Kibana should try another route with a lib that does better.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.