Getting CLA not signed error on my PR, when I have signed it


I submitted a pull request for adding a feature requested in the issue.I have signed the CLA for Elastic already but the bot still hasn't detected that and it prevents me from requesting a review and get my pull request merged successfully. Can someone please help me out on this?

Hi @baba_yaga - It seems that the commit metadata does not match the information provided when you signed the CLA.

The CLA contains the same Gmail email address listed in your GH repository - however the commit metadata has a different email address. From the look of it, I believe it is a typo issue in the address provided in the commit metadata. If you were to fix the commit metadata and provide the right email address (matching the one provided in the CLA), you should be good to go.

I hope that helps.

1 Like

Thanks @ropc ! That fixed it and now all checks are complete.

1 Like

I'm having the same issue and have tried all combinations for my PR Added double quotations to command for Windows by catonice · Pull Request #12704 · elastic/logstash · GitHub

@theonlycatonice - Welcome to our community forum! :slight_smile:

I cannot find any signed agreement in our backend that matches your Github username and associated email address. Please sign the Contributor Agreement.

Take note also that the commit metadata has a different email address compared to your email address associated in your Github profile. You should edit it accordingly once you have signed the agreement.

Let us know how it goes. Thank you.

Is there a way for me to see the metadata? Because I only have 2 emails associated with my account, 1 name and 1 username and I think I tried just about every combo :confused:

@theonlycatonice - Thank you for signing the Contributor Agreement. I re-ran the checks and it is now all good.

Is there a way for me to see the metadata?

You could run the following command line:

  • git show commit_number | grep Author (e.g git show 22d8d304e | grep Author).
1 Like