Getting following error when starting kibana 5.6


(Chirag) #1

log [00:06:09.483] [info][status][ui settings] Status changed from uninitialized to yellow - Elasticsearch plugin is yellow
log [00:06:09.496] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "default"
log [00:06:10.535] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "url"
log [00:06:10.926] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "server"
log [00:06:11.268] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [00:06:11.293] [error][status][plugin:elasticsearch@5.6.2] Status changed from yellow to red - [remote_transport_exception] [_F5SYeT][10.1.0.6:9300][indices:admin/mapping/put]
log [00:06:11.295] [error][status][ui settings] Status changed from yellow to red - Elasticsearch plugin is red
log [00:06:13.837] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [00:06:16.400] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"

Using predefined mapping for .kibana index in ES

{
"mappings":{
"config":{
"properties":{
"buildNum":{
"type":"keyword"
}
}
},
"index-pattern":{
"properties":{
"fieldFormatMap":{
"type":"text"
},
"fields":{
"type":"text"
},
"intervalName":{
"type":"keyword"
},
"notExpandable":{
"type":"boolean"
},
"sourceFilters":{
"type":"text"
},
"timeFieldName":{
"type":"keyword"
},
"title":{
"type":"text"
}
}
},
"visualization":{
"properties":{
"description":{
"type":"text"
},
"kibanaSavedObjectMeta":{
"properties":{
"searchSourceJSON":{
"type":"text"
}
}
},
"savedSearchId":{
"type":"keyword"
},
"title":{
"type":"text"
},
"uiStateJSON":{
"type":"text"
},
"version":{
"type":"integer"
},
"visState":{
"type":"text"
}
}
},
"search":{
"properties":{
"columns":{
"type":"keyword"
},
"description":{
"type":"text"
},
"hits":{
"type":"integer"
},
"kibanaSavedObjectMeta":{
"properties":{
"searchSourceJSON":{
"type":"text"
}
}
},
"sort":{
"type":"keyword"
},
"title":{
"type":"text"
},
"version":{
"type":"integer"
}
}
},
"dashboard":{
"properties":{
"description":{
"type":"text"
},
"hits":{
"type":"integer"
},
"kibanaSavedObjectMeta":{
"properties":{
"searchSourceJSON":{
"type":"text"
}
}
},
"optionsJSON":{
"type":"text"
},
"panelsJSON":{
"type":"text"
},
"refreshInterval":{
"properties":{
"display":{
"type":"keyword"
},
"pause":{
"type":"boolean"
},
"section":{
"type":"integer"
},
"value":{
"type":"integer"
}
}
},
"timeFrom":{
"type":"keyword"
},
"timeRestore":{
"type":"boolean"
},
"timeTo":{
"type":"keyword"
},
"title":{
"type":"text"
},
"uiStateJSON":{
"type":"text"
},
"version":{
"type":"integer"
}
}
},
"url":{
"properties":{
"accessCount":{
"type":"long"
},
"accessDate":{
"type":"date"
},
"createDate":{
"type":"date"
},
"url":{
"type":"text",
"fields":{
"keyword":{
"type":"keyword",
"ignore_above":2048
}
}
}
}
},
"server":{
"properties":{
"uuid":{
"type":"keyword"
}
}
},
"timelion-sheet":{
"properties":{
"description":{
"type":"text"
},
"hits":{
"type":"integer"
},
"kibanaSavedObjectMeta":{
"properties":{
"searchSourceJSON":{
"type":"text"
}
}
},
"timelion_chart_height":{
"type":"integer"
},
"timelion_columns":{
"type":"integer"
},
"timelion_interval":{
"type":"keyword"
},
"timelion_other_interval":{
"type":"keyword"
},
"timelion_rows":{
"type":"integer"
},
"timelion_sheet":{
"type":"text"
},
"title":{
"type":"text"
},
"version":{
"type":"integer"
}
}
}
}
}


(Chris Roberson) #2

Hey there,

Did you upgrade to 5.6 from an older version of the Elastic Stack? Or is it a fresh install? If its the former, there was an issue upgrading from 2.x to 5.6 that is discussed here.

Let me know if that helps. If not, can you please provide more information about your setup and possibly more of the log that might include a more detailed error message?

Thanks,
Chris


(Chirag) #3

Hi Chris

This is fresh installation of Kibana 5.6.2. I had schema files from old kibana 4.5 and ES 2.3.3 which I modified accordingly for kibana 5.6.2. The fix your mentioned in the link looks like is already committed to Kibana 5.6.1

I am running kibana 5.6.2 in a docker container on top of alpine. Following are the complete logs after starting kibana

log [22:15:00.715] [warning][config] Settings for "xpack" were not applied, check for spelling errors and ensure the plugin is loaded.
log [22:15:01.243] [info][status][plugin:kibana@5.6.2] Status changed from uninitialized to green - Ready
log [22:15:01.356] [info][status][plugin:elasticsearch@5.6.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [22:15:01.401] [info][status][plugin:console@5.6.2] Status changed from uninitialized to green - Ready
log [22:15:01.433] [info][status][plugin:metrics@5.6.2] Status changed from uninitialized to green - Ready
log [22:15:01.479] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "default"
log [22:15:01.758] [info][status][plugin:timelion@5.6.2] Status changed from uninitialized to green - Ready
log [22:15:01.765] [info][listening] Server running at http://0:5601
log [22:15:01.767] [info][status][ui settings] Status changed from uninitialized to yellow - Elasticsearch plugin is yellow
log [22:15:02.031] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "url"
log [22:15:02.367] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "server"
log [22:15:02.734] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:02.760] [error][status][plugin:elasticsearch@5.6.2] Status changed from yellow to red - [illegal_argument_exception] mapper [hits] cannot be changed from type [long] to [integer]
log [22:15:02.762] [error][status][ui settings] Status changed from yellow to red - Elasticsearch plugin is red
log [22:15:05.307] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:07.862] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:10.410] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:12.957] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:15.514] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:18.071] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:20.615] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"
log [22:15:23.162] [info][elasticsearch] Adding mappings to kibana index for SavedObject type "timelion-sheet"


(Chris Roberson) #4

Thanks Chirag,

The error is mapper [hits] cannot be changed from type [long] to [integer]. Can you paste the mappings related to the index that uses this field?


(Chirag) #5

I have timelion-sheet mapping for .kibana index which have hits field which I changed from long to integer. I tried to push this mapping into ES. But looks like this is dynamic mapping and kibana automatically create this mapping in ES after kibana is started. Thats when error occur because kibana is putting hits field as long but ES want it as integer

"timelion-sheet": {
"properties": {
"description": {
"type": "text"
},
"hits": {
"type": "integer"
},
"kibanaSavedObjectMeta": {
"properties": {
"searchSourceJSON": {
"type": "text"
}
}
},
"timelion_chart_height": {
"type": "integer"
},
"timelion_columns": {
"type": "integer"
},
"timelion_interval": {
"type": "keyword"
},
"timelion_other_interval": {
"type": "keyword"
},
"timelion_rows": {
"type": "integer"
},
"timelion_sheet": {
"type": "text"
},
"title": {
"type": "text"
},
"version": {
"type": "integer"
}
}
}


(Chris Roberson) #6

Hi Chirag,

Please see this comment for a possible way to resolve this issue.

Let me know if that helps.

Thanks,
Chris


(Chirag) #7

I saw that, but I cannot pre-create .kibana index in ES. I am not sure if it is already resolved in latest release after 5.6.2


(Chris Roberson) #8

Hi Chirag,

Unfortunately, a fix is not yet available.

Have you tried using the Upgrade Assistant to handle the re-indexing?


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.