Getting [marvel.agent.exporter ] [Tempest] remote target didn't respond with 200 OK response code [404 Not Found

My two clusters, currently default named, Tempest and Morg, appear to be
working fine. The head plugin shows green and queries work. I have indices
and documents added.

When I added Marvel, restarted both nodes, I see the error
[marvel.agent.exporter ] [Tempest] remote target didn't respond with
200 OK response code [404 Not Found
repeated in each cluster's log files (with the names changed accordingly).

Marvel has a blank screen and reports "No results There were no results
because no indices were found that match your selected time span".

I am running version 1.0.1 on each server, have Java (build 1.7.0_25-b15)
on each. No configuration changes were made -- meaning no marvel.agent
properties were set in the configuration.
I do have
discovery.zen.ping.multicast.enabled: false

Any suggestions?

thanks,

Dennis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7aaece0e-3d3b-4798-aacc-f71f53ecbe53%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Dennis,

Do you have action.auto_create_index: false in your elasticsearch.yml? if
so
see http://www.elasticsearch.org/guide/en/marvel/current/#relevant-settings

Cheers,
Boaz

On Thursday, March 20, 2014 1:35:05 AM UTC+1, Dennis Andersen wrote:

My two clusters, currently default named, Tempest and Morg, appear to be
working fine. The head plugin shows green and queries work. I have indices
and documents added.

When I added Marvel, restarted both nodes, I see the error
[marvel.agent.exporter ] [Tempest] remote target didn't respond with
200 OK response code [404 Not Found
repeated in each cluster's log files (with the names changed accordingly).

Marvel has a blank screen and reports "No results There were no results
because no indices were found that match your selected time span".

I am running version 1.0.1 on each server, have Java (build 1.7.0_25-b15)
on each. No configuration changes were made -- meaning no marvel.agent
properties were set in the configuration.
I do have
discovery.zen.ping.multicast.enabled: false

Any suggestions?

thanks,

Dennis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7dbc30b6-0c5f-4776-b550-d842a8b4bda2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Yes, that was it! Thanks!

Dennis

On Friday, March 21, 2014 11:29:13 AM UTC-7, Boaz Leskes wrote:

Hi Dennis,

Do you have action.auto_create_index: false in your elasticsearch.yml? if
so see
http://www.elasticsearch.org/guide/en/marvel/current/#relevant-settings

Cheers,
Boaz

On Thursday, March 20, 2014 1:35:05 AM UTC+1, Dennis Andersen wrote:

My two clusters, currently default named, Tempest and Morg, appear to be
working fine. The head plugin shows green and queries work. I have indices
and documents added.

When I added Marvel, restarted both nodes, I see the error
[marvel.agent.exporter ] [Tempest] remote target didn't respond with
200 OK response code [404 Not Found
repeated in each cluster's log files (with the names changed accordingly).

Marvel has a blank screen and reports "No results There were no results
because no indices were found that match your selected time span".

I am running version 1.0.1 on each server, have Java (build 1.7.0_25-b15)
on each. No configuration changes were made -- meaning no marvel.agent
properties were set in the configuration.
I do have
discovery.zen.ping.multicast.enabled: false

Any suggestions?

thanks,

Dennis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0b2ed392-ea0b-4641-ac41-413d5a67b188%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

If I set action.auto_create_index to false and I've setup a separate
Elasticsearch cluster for Marvel indices, will I still face this issue?

On Friday, March 21, 2014 at 11:59:13 PM UTC+5:30, Boaz Leskes wrote:

Hi Dennis,

Do you have action.auto_create_index: false in your elasticsearch.yml? if
so see
http://www.elasticsearch.org/guide/en/marvel/current/#relevant-settings

Cheers,
Boaz

On Thursday, March 20, 2014 1:35:05 AM UTC+1, Dennis Andersen wrote:

My two clusters, currently default named, Tempest and Morg, appear to be
working fine. The head plugin shows green and queries work. I have indices
and documents added.

When I added Marvel, restarted both nodes, I see the error
[marvel.agent.exporter ] [Tempest] remote target didn't respond with
200 OK response code [404 Not Found
repeated in each cluster's log files (with the names changed accordingly).

Marvel has a blank screen and reports "No results There were no results
because no indices were found that match your selected time span".

I am running version 1.0.1 on each server, have Java (build 1.7.0_25-b15)
on each. No configuration changes were made -- meaning no marvel.agent
properties were set in the configuration.
I do have
discovery.zen.ping.multicast.enabled: false

Any suggestions?

thanks,

Dennis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fb82f4-40d2-4ae4-ad66-a3f7ea13898d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

No. The auto create needs to be enabled (or set to marvel-*) on the cluster that will store your marvel data. Using a separated monitoring cluster means that your production cluster can have it disabled

On Fri, Feb 27, 2015 at 6:00 AM, Mouzer bittusrk@gmail.com wrote:

If I set action.auto_create_index to false and I've setup a separate
Elasticsearch cluster for Marvel indices, will I still face this issue?
On Friday, March 21, 2014 at 11:59:13 PM UTC+5:30, Boaz Leskes wrote:

Hi Dennis,

Do you have action.auto_create_index: false in your elasticsearch.yml? if
so see
http://www.elasticsearch.org/guide/en/marvel/current/#relevant-settings

Cheers,
Boaz

On Thursday, March 20, 2014 1:35:05 AM UTC+1, Dennis Andersen wrote:

My two clusters, currently default named, Tempest and Morg, appear to be
working fine. The head plugin shows green and queries work. I have indices
and documents added.

When I added Marvel, restarted both nodes, I see the error
[marvel.agent.exporter ] [Tempest] remote target didn't respond with
200 OK response code [404 Not Found
repeated in each cluster's log files (with the names changed accordingly).

Marvel has a blank screen and reports "No results There were no results
because no indices were found that match your selected time span".

I am running version 1.0.1 on each server, have Java (build 1.7.0_25-b15)
on each. No configuration changes were made -- meaning no marvel.agent
properties were set in the configuration.
I do have
discovery.zen.ping.multicast.enabled: false

Any suggestions?

thanks,

Dennis

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/IfyoSgZgR9E/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fb82f4-40d2-4ae4-ad66-a3f7ea13898d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1425020890325.e102d9%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.