Marvel Agent Ignoring settings and writing locally

monitoring

(flyingrabbit) #1

Hi All, Thanks for any advice anyone can give on this issue!
My setting for Marvel agent in my production cluster is
marvel.agent.exporters
id1:
type: http
host: ["http://MonitoringNodeName:9200/"

I can get to http://MonitoringNodeName:9200/ from any node in the production cluster and see head for example.

But for some reason I get a lot of index not found errors in the main cluster log. Then just for the heck of it I manually created the index with today's date on the production cluster.

It immediately started filling with data. Why is the marvel.agent.exporters setting being ignored?


(Chris Earle) #2

YAML is very sensitive to whitespace. Your issue is most likely related to that:

marvel.agent.exporters
  id1:
    type: http
    host: ["http://MonitoringNodeName:9200/"]

You were also missing a ] at the end of the example, but hopefully it was just a copy/paste issue.


(flyingrabbit) #3

Hi pickypg,

How do you post the code on this forum so it displays correctly?


(system) #4