Getting problems in install Watcher

alerting

(reli) #1

I install Watcher as i see in the "getting-started" docs,

bin/plugin -i elasticsearch/watcher/my_key

and service elasticsearch restart

I get the following error "elasticsearch dead but subsys locked" and nothing worked even this link did not help me...

http://elasticsearch-users.115913.n3.nabble.com/elasticsearch-dead-but-subsys-locked-td4062115.html

elasticsearch came back to life only when i uninstall watcher


(Mark Walkom) #2

Is there anything in the Elasticsearch logs?


(reli) #3

In the log file i see
" Error injecting constructor, java.lang.NoSuchMethodError: org.elasticsearch.discovery.zen.ZenDiscovery.(Lorg/elasticsearch/common/settings/Settings;Lorg/elasticsearch/cluster/ClusterName;Lorg/elasticsearch/threadpool/ThreadPool;Lorg/elasticsearch/transport/TransportService;Lorg/elasticsearch/cluster/ClusterService;Lorg/elasticsearch/node/settings/NodeSettingsService;Lorg/elasticsearch/cluster/node/DiscoveryNodeService;Lorg/elasticsearch/discovery/zen/ping/ZenPingService;Lorg/elasticsearch/discovery/zen/elect/ElectMasterService;Lorg/elasticsearch/discovery/DiscoverySettings;)V
at org.elasticsearch.discovery.ec2.Ec2Discovery.(Unknown Source)
while locating org.elasticsearch.discovery.ec2.Ec2Discovery
while locating org.elasticsearch.discovery.Discovery
for parameter 3 at org.elasticsearch.node.service.NodeService.(Unknown Source)
while locating org.elasticsearch.node.service.NodeService
for parameter 5 at org.elasticsearch.action.admin.cluster.node.stats.TransportNodesStatsAction.(Unknown Source)......"
whene i remark discovery.type: ec2 in the yml file.
its work now, but why?i need this seeting.


(Mark Walkom) #4

Hmm that is odd.
I'll point the Watcher and the AWS plugin team here and maybe they can assist.


(Mark Walkom) #5

What ES version are you on?
What version of the AWS plugin is installed?


(reli) #6

I run this
/bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.4.1


(Mark Walkom) #7

What ES version are you on


Errors when answering by email
(Martijn Van Groningen) #8

Version 2.4.1 isn't compatible with ES 1.5, you need to install version 2.5.1:

Can you run the following command:
bin/plugin install elasticsearch/elasticsearch-cloud-aws/2.5.1


(reli) #9

Now it works, thank you very much! :thumbsup:


(system) #10