Getting the error after upgrading from v6 to v7

Hi ES community,

I have one question recently i have done reindexing then ES up-gradation from v6.8.23 to v7.17.9. After this operation i noticed some error in elastic-search.

Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations a
re disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [TARGET_NAME] in order to load field data by uninverting the inverted index.

I would like to know How can i change this default option and what would be the step?


Hi @sonujatav35,

It looks like you are performing aggregations (perhaps in some dashboard visualizations) using a text type field rather than a keyword type field. Are you able to change your query/ visualization to use the keyword field instead?

Thanks for the suggestion as of now I have not updated my query but let me try update it accordingly. If i do not want to change Dashboards visualizations query then this(fielddata=true) option i have to append to my query?

You would need to amend the index mapping. There is an update example here. However I would read the caveats listed here carefully as there is a memory impact of enabling this setting.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.