Ha Proxy integration issues


I'm trying to make the HA Proxy integration working on my ELK stack. I'm able to gather the system metrics as expected, so I tried to add the HA Proxy integration on my hosts with HA proxy servers running.
So what I've done basically on my haproxy.cfg was adding these line to gather the stats from TCP socket :

stats socket

And configured rsyslog to redirect syslog messages from HA proxy to an open UDP port. Content of /etc/rsyslog.d/haproxy.conf

# Create an additional socket in haproxy's chroot in order to allow logging via
# /dev/log to chroot'ed HAProxy processes
$AddUnixListenSocket /var/lib/haproxy/dev/log

# Send HAProxy messages to a dedicated logfile
:programname,startswith,"haproxy" @

With all of these running with default integration settings :

After all services restarted, I have some inputs regarding my HA proxy and visible on the dedicated dashboards. But it looks like I only have a half of them (like no downtime, no connection per server, etc) :

Also no results on the logs overview :

I tried to get deeper by modifying HA proxy.cfg and sending logs directly to, testing out the different ports, etc

Has anyone managed to make the integration working ? Or would have an idea ?
Thank you

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.