Head plugin unable to connect to Elasticsearch 5.3 - cluster health: not connected


(Kontranavoj) #1

Hi guys,

I have Elasticsearch 5.3 installed on Centos 7 x64 server.

Also, I have started Head plugin with built-in web server, following next steps:

git clone git://github.com/mobz/elasticsearch-head.git
cd elasticsearch-head
npm install
npm run start

After this, I can login to Head webinterface, but cannot connect to the Elasticsearch server. Getting message

cluster health: not connected

when I try to connect to http://localhost:9200/.

Can somebody tell me why I cannot install head plugin using elasticsearch-plugin command. I tried it using the following command:

/usr/share/elasticsearch/bin/elasticsearch-plugin install elasticsearch-head

but without success (getting following message):

ERROR: Unknown plugin elasticsearch-head

In older Elasticsearch versions, Head plugin had to be installed by command

/usr/share/elasticsearch/bin/plugin install mobz/elasticsearch-head

but this is not working anymore.

Can somebody help me to get Head plugin working with actual Elasticsearch version?


(Mark Walkom) #2

Site plugins are no longer supported in 5.X so you cannot install it into ES.

You may need to ask on the head GH page though, as I don't know what this could be :slight_smile:


(Denise) #3

I'm having the same issue.

Also cloned the repo, installed and ran. Since plugins are not supported with version 5.x.

I have the same result, I can bring the "plugin" up in the browser but elasticsearch-head cannot connect to my es instance.


Localhost:9200/_plugin/head error
(Kontranavoj) #4

Hi guys,

I resolved this issue by installing x-pack module which now have native support for Elasticsearch, Kibana and Logstash monitoring.

It looks great and fully meets all of my needs. Also, it is working without any issues.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.