Heartbeat Dashboard Questions


(Ninoslav) #1

Hi guys, I have a few questions about hearthbeat.

I am using ELK stack 6.0.0, and I have successfully installed hearthbeat, hearthbeat template, and dashboard.
But I`am experiencing some limitations, which I'm not sure are they by designed or some kind of error.

So in my hearthbeat.yml file I have defined more than 5 hosts to monitor, but in my dashboard in kibana, it only displays max 5 hosts, no mater what i do max number of hosts displayed is 5, so i am not sure is it by design, or is there some error that i a doing.

The other thing, that is bothering me is that I have set up icmp, and tcp monitors, and in my kibana, when i go to discover tab, i see the logs(messages) coming form icmp/tcp monitors, but there is no dashboard for icmp/tcp monitors. In /usr/share/heartbeat/kibana/default/dashboard there is only Heartbeat-http-monitor.json, so i am not shure is there no dashboard for icmp/tcp monitors, or am I doing something wrong.

Here is my hearthbeat.yml file:

heartbeat.monitors:
- type: http

  # List or urls to query
  urls: ["http://myhostip:5601"]

  # Configure task schedule
  schedule: '@every 10s'

  # Total test connection and data exchange timeout
  #timeout: 16s

- type: http
  urls: ["http://somehostip:80"]
  schedule: '@every 10s'

- type: http
  urls: ["http://somehostip:80"]
  schedule: '@every 10s'

- type: http
  urls: ["http://somehostip:80"]
  schedule: '@every 10s'

- type: http
  urls: ["http://somehostip:80"]
  schedule: '@every 10s'

- type: http
  urls: ["http://somehostip:80"]
  schedule: '@every 10s'

- type: icmp
  schedule: '@every 5s' 
  hosts: ["somehostIP"]

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression

tags: ["service-X", "web-tier"]

setup.dashboards.enabled: true
 
setup.kibana:
  host: "mykibanahost:5601"

output.elasticsearch:
  hosts: ["10.129.0.17:9200"]

Thanks for help.

Ninoslav.


(Carlos Pérez Aradros) #2

Hi @Ninoslav,

We don't ship dashboards for all the use cases. The one that you are seeing is the only one at the moment. The good news is that Kibana is very flexible and you can edit it, or create a new one on top of it to adjust it to your needs.

For instance, the max of 5 hosts is not a hard limit, it's just the visualization in the dashboards is limited to that, you can edit it and set a new limit.

As for the other protocols, you will need to edit the visualizations to include them.

Please consider contributing if you come up with something cool that may benefit others: https://www.elastic.co/guide/en/beats/devguide/6.2/new-dashboards.html

Best regards


(Ninoslav) #3

Hi Exekias,

Thank you for quick answer,

The thing is that when i go to;

visualize -> HTTP monitors -> Options -> Per page

number is set to 10, but it is still displaying 5 hosts, when i lower it to less than 5 it takes hosts out, but by increasing a number over 5 it just displays extra blank rows.

If I type in textbox IP of my host it displays every host that i have (more than 5), but on HTTP monitor, it only displays 5 per page :confused:

Is there some config file that could be tempered, to get a desired functionality?

Cheers.

Ninoslav.


(Carlos Pérez Aradros) #4

Could you share a screenshot to see what we are talking about?


(Andrew Kroh) #5

You also need to adjust the aggregations (Buckets) used in the visualization. In Kibana they usually default to max 5 to make the requests to ES less expensive.


(Ninoslav) #6

Hi Exekias,

Is this good enough?

Visualization:

Dashboard:


(Ninoslav) #7

Hi Andrewkroh,

Thank you for your answer, it solved my problem. :wink:

Thanks a lot m8.

Cheers.

Ninoslav.


(Ninoslav) #8

Exekias,

This post can be marked as resolved, and closed.

Thanks for help.

Cheers.

Ninoslav.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.