Heartbeat monitor fails with io error 'EOF'


I'm trying to do a check on philips-hue.com and my monitor is not giving the correct response. It is showing an io error with EOF in the message. I've been trying to find out why it fails, but am not successful yet:

  • Expected an issue with Let's Encrypt, but another Let's Encrypt url works fine
  • I tried wget/curl on the server which initially failed on Let's Encrypt and therefor updated the ca certificates package
  • I tried to disable the verification fully

Does someone have any pointers?

error.message: Get "https://www.philips-hue.com/nl-nl": EOF
error.type: io
- type: http
  # ID used to uniquely identify this monitor in elasticsearch even if the config changes
  id: hue-monitor
  # Human readable display name for this service in Uptime UI and elsewhere
  name: Hue Monitor
  # List or urls to query
  urls: ["https://www.philips-hue.com/nl-nl"]
  ssl.verification_mode: none

  # Configure task schedule
  schedule: '@every 60s'
  # Total test connection and data exchange timeout
  #timeout: 16s
  # Name of corresponding APM service, if Elastic APM is in use for the monitored service.
  #service.name: my-apm-service-name

Hi @SanderP
I am unable to reproduce the issue locally at least on the master branch, can you please tell me which heartbeat version are you using?

Also do you have any network restrictions in place, behind proxy or firewall or something? which is preventing heartbeat from reaching the monitor url.


Hi @shahzad31

It is heartbeat version 7.15.1 (amd64), libbeat 7.15.1 [5ae799cb1c3c490c9a27b14cb463dc23696bc7d3 built 2021-10-07 22:12:50 +0000 UTC]

There is a transparent proxy, but the interesting part is that other URLs worked fine, including urls also managed with Let's Encrypt certificates. For this reason I created this topic for any pointers.

I'll retest the monitor with an explicit proxy from my side.

Hi @shahzad31

The issue indeed seems to be related to the whitelisting rules which are getting adjusted.
Thanks for the validation still!


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.