Heatmap Y-Axis reversed

Same issue as Heat map Y-axis reverse order

Looks still unfixed after more than 2 years, any chance it will be worked on?

Looks still unfixed after more than 2 years, any chance it will be worked on?

As this is expected behavior and not a bug, it's not on our radar to add this feature as long as there is no feature request. Kibana is using this forum to answer questions around the product, but Github issues to track features and bugs.

I didn't find a similar issue already covering this in the Kibana repository. If you think this is an important feature which should get added to Kibana, feel free to open one here: https://github.com/elastic/kibana/issues/new?template=Feature_request.md

Ok, looks like I found a way to get what I want. Kibana is just showing whatever it gets from ES, and the default for histograms is to sort by key ascending. Luckily the Histogram aggregation supports the order setting with the same functionality as the Terms aggregation, and Kibana lets you add custom JSON to the aggregation.

So, my solution is to add {"order": {"_key": "desc"}} in the "JSON input" field:

Note that it might still not work fully as intended unless "Show empty buckets" is selected and "Extended bounds" are specified, depending on how the data comes in. But that's a separate bug.

(@flash1293 Do you think you could add a link to this "solution" to the original topic? It might help someone)

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.