How Can I set USer Security to Only view a dashboard


(Perry) #1

I have create a couple of Dashboards and now I want to create a user that is allowed to view these dashboards. I want the user to be able to change the date range on the search as well as filter the data using the search filter bar. I have created a Role and copied the setting in the Kibana_user role. Only change I made was to the indices was to reflect the data I use for the Dashboards.

I then created my user and assigned the new role to the new user. I can logon on using the new user account but I cannot view anything. If I clack on Dashboards nothing comes up.

What am I missing here? I have also added view_index_metadata as suggested by another post but that did not help,


(Spencer Alger) #2

Can you please post more information about the roles the user has assigned, and the location of the data? Index names and copies/screenshots of the roles you're using would be helpful


(Perry) #3

Thank you for your response. The user is assigned this role

And here is a screen shot of the users settings:

The data and index is named updstats.

Thanks Perry


(Spencer Alger) #4

The user needs read access to the .kibana index in order to see the dashboards available.

Also, your UPDStatsReadOnly role is giving index privileges to the user, which allows them to add and update documents in the index. See https://www.elastic.co/guide/en/x-pack/current/security-privileges.html#privileges-list-indices


(Perry) #5

I have removed the index privileges from the role. However when I attempt to add the .kibana index to the user I cannot find that index on my list. Does mu sysadmin need to do something to create that index?

Thanks Perry


(Spencer Alger) #6

If kibana is running then the kibana index should exist. It's possible that your installation is using a custom kibana index name, so I would check with your sysadmin


(Perry) #7

Tanks Spencer appreciate your help.

Thanks Perry


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.