How can I suspend incoming data flow from server?


#1

I unfortunately introduced an error in my pipeline seetings, and now it is generating so much errors and traffic, that I can't even edit the pipeline back. In the console I get

{
"statusCode": 504,
"error": "Gateway Time-out",
"message": "Client request timeout"
}

And using curl I get

{"error":{"root_cause":[{"type":"process_cluster_event_timeout_exception","reason":"failed to process cluster event (put-pipeline-lgw) within 30s"}],"type":"process_cluster_event_timeout_exception","reason":"failed to process cluster event (put-pipeline-lgw) within 30s"},"status":503}

I've tried increasing the master_timeout to 10 minutes for my PUT call, but it didn't go through.

How I can suspend all bulk and ingest traffic as I don't have control over the filebeat clients?


(Mark Walkom) #2

Use a firewall or similar.


#3

Hi @warkolm,

Thanks for the suggestion, I managed the security settings on the Openstack instance and it helped. I seem to force myself too much in thinking in the box.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.