How could I reset the cluster configuration value


(Pavel P) #1

Hi,

Once I've set the configuration value from default to some custom, like
this way:

curl -XPUT http://localhost:9200/_cluster/settings -d '

{
"transient": {
"indices.fielddata.breaker.limit": "40%"
}
}
'

So I have this:

https://lh6.googleusercontent.com/-y3QaJEqbbOE/U-Sy9-MGw0I/AAAAAAAAAIs/wLbg4lSRymQ/s1600/Screen%2BShot%2B2014-08-08%2Bat%2B2.22.13%2BPM.png

How then could I reset it back to default?

Tries this:
curl -XDELETE http://morbius.kreditech.com:9200/_cluster/settings -d '
{
"persistent" : {
"indices.fielddata.breaker.limit"
}
}'

With no luck.

Here it's stated that it's somehow
fixed https://github.com/elasticsearch/elasticsearch/issues/3670 , but I
don't see any example.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4afdd828-64b1-4c60-b10b-8ff0d6cebd04%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

It's not fixed, it's been moved to

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 21:31, Pavel P pavel@kredito.de wrote:

Hi,

Once I've set the configuration value from default to some custom, like
this way:

curl -XPUT http://localhost:9200/_cluster/settings -d '

{
"transient": {
"indices.fielddata.breaker.limit": "40%"
}
}
'

So I have this:

https://lh6.googleusercontent.com/-y3QaJEqbbOE/U-Sy9-MGw0I/AAAAAAAAAIs/wLbg4lSRymQ/s1600/Screen%2BShot%2B2014-08-08%2Bat%2B2.22.13%2BPM.png

How then could I reset it back to default?

Tries this:
curl -XDELETE http://morbius.kreditech.com:9200/_cluster/settings -d '
{
"persistent" : {
"indices.fielddata.breaker.limit"
}
}'

With no luck.

Here it's stated that it's somehow fixed
https://github.com/elasticsearch/elasticsearch/issues/3670 , but I don't
see any example.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4afdd828-64b1-4c60-b10b-8ff0d6cebd04%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4afdd828-64b1-4c60-b10b-8ff0d6cebd04%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQauycYVcLjma%3DHg2%2BxNY6KkapxW%3DPu9jvG-fdF4fAiA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3