Cluster ignores configuration changes via API


(Robin Verlangen) #1

Hi there,

I'm trying to adjust some settings persistently through the API.

For example setting the default number of shards:

CURL Apply change:
curl -XPUT localhost:9200/_cluster/settings -d '{ "persistent" : {
"index.number_of_shards" : 2 } }'

Change Response
{"acknowledged":true,"persistent":{},"transient":{}}

CURL List settings
curl -XGET localhost:9200/_cluster/settings

Settings Response
{"persistent":{},"transient":{}}

Any ideas what's going on? I run version 1.0.0

Best regards,

Robin Verlangen
Chief Data Architect

W http://www.robinverlangen.nl
E robin@us2.nl

http://goo.gl/Lt7BC
What is CloudPelican? http://goo.gl/HkB3D

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADVHTB_VEk%3Du%2Br38Dept_vwwTCqYJBGn13P02A3ucXq6TtRY6g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #2

You can even put an invalid setting such as { "foo" : "bar" } and no error
will be returned. This behavior has always been the norm and I agree with
you that invalid settings should be not ignored but an explicit error
should be thrown.

BTW, here is a list of valid settings:

https://github.com/elasticsearch/elasticsearch/blob/master/src/main/java/org/elasticsearch/index/settings/IndexDynamicSettingsModule.java

Cheers,

Ivan

On Wed, May 21, 2014 at 10:55 AM, Robin Verlangen robin@us2.nl wrote:

Hi there,

I'm trying to adjust some settings persistently through the API.

For example setting the default number of shards:

CURL Apply change:
curl -XPUT localhost:9200/_cluster/settings -d '{ "persistent" : {
"index.number_of_shards" : 2 } }'

Change Response
{"acknowledged":true,"persistent":{},"transient":{}}

CURL List settings
curl -XGET localhost:9200/_cluster/settings

Settings Response
{"persistent":{},"transient":{}}

Any ideas what's going on? I run version 1.0.0

Best regards,

Robin Verlangen
Chief Data Architect

W http://www.robinverlangen.nl
E robin@us2.nl

http://goo.gl/Lt7BC
What is CloudPelican? http://goo.gl/HkB3D

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADVHTB_VEk%3Du%2Br38Dept_vwwTCqYJBGn13P02A3ucXq6TtRY6g%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CADVHTB_VEk%3Du%2Br38Dept_vwwTCqYJBGn13P02A3ucXq6TtRY6g%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDSz3ngTo-e3wAdGt6Emdsh4%2BgXz1%2ButL1MTcA6W%2BOz%2BQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Robin Verlangen) #3

Thanks, makes sense. I'll create an issue on this.

Best regards,

Robin Verlangen
Chief Data Architect

W http://www.robinverlangen.nl
E robin@us2.nl

http://goo.gl/Lt7BC
What is CloudPelican? http://goo.gl/HkB3D

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

On Thu, May 22, 2014 at 4:57 PM, Ivan Brusic ivan@brusic.com wrote:

You can even put an invalid setting such as { "foo" : "bar" } and no
error will be returned. This behavior has always been the norm and I agree
with you that invalid settings should be not ignored but an explicit error
should be thrown.

BTW, here is a list of valid settings:

https://github.com/elasticsearch/elasticsearch/blob/master/src/main/java/org/elasticsearch/index/settings/IndexDynamicSettingsModule.java

Cheers,

Ivan

On Wed, May 21, 2014 at 10:55 AM, Robin Verlangen robin@us2.nl wrote:

Hi there,

I'm trying to adjust some settings persistently through the API.

For example setting the default number of shards:

CURL Apply change:
curl -XPUT localhost:9200/_cluster/settings -d '{ "persistent" : {
"index.number_of_shards" : 2 } }'

Change Response
{"acknowledged":true,"persistent":{},"transient":{}}

CURL List settings
curl -XGET localhost:9200/_cluster/settings

Settings Response
{"persistent":{},"transient":{}}

Any ideas what's going on? I run version 1.0.0

Best regards,

Robin Verlangen
Chief Data Architect

W http://www.robinverlangen.nl
E robin@us2.nl

http://goo.gl/Lt7BC
What is CloudPelican? http://goo.gl/HkB3D

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADVHTB_VEk%3Du%2Br38Dept_vwwTCqYJBGn13P02A3ucXq6TtRY6g%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CADVHTB_VEk%3Du%2Br38Dept_vwwTCqYJBGn13P02A3ucXq6TtRY6g%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDSz3ngTo-e3wAdGt6Emdsh4%2BgXz1%2ButL1MTcA6W%2BOz%2BQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDSz3ngTo-e3wAdGt6Emdsh4%2BgXz1%2ButL1MTcA6W%2BOz%2BQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADVHTB8zAeE_c83763k6i2vxAJbYCo5M%2BWzj4HuQgtCkuXZyQA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4