How could I restore snapshot from another elasticsearch server's repository?

I have two different Elasticsearch clusters (for example, the name of the server is test-elk-ver6 and test-elk-ver7) which has run on the different server.

I want to migrate the data from test-elk-ver6 to test-elk-ver7, so I tried to take a snapshot of test-elk-ver6 at test-elk-ver6's local repository, then restore it at the test-elk-ver7.

However, it seems like that there is no way to register test-elk-ver6's repository on the test-elk-ver7. (Or maybe I didn't know how I could)

I have read the Read-only URL repository, but I have no idea how to specify test-elk-ver6's repository to "settings".

PUT /_snapshot/my_read_only_url_repository
  "type": "url",
  "settings": {
    // how could specify the repository? just location of the repository will be enough?
    "url": "http://{test-elk-ver6's ip addr}/????" 

Should I just zip the snapshot from the test-elk-ver6 and move it to the test-elk-ver7 for restoring it? Or is there any way to register the repository from another server?

Just using Nginx for routing the repository's path, then everything solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.