How do you install Marvel in windows?

Am using windows not linux

Please be specific.
What errors? What commands are you running.

Simply stating "it doesn't work" is only frustrating yourself and us.

The Kibana link says this: Elasticsearch instance

From:

Extract your archive

Open config/kibana.yml in an editor

Set the elasticsearch.url to point at your Elasticsearch instance

Please reply

I am waiting....!

This is just what I want to know please!

URL of the Elasticsearch instance you want to connect to.

What is this url and Elasticsearch instance? Please provide a sample.

The elasticsearch url you need is written in the log you posted:

[Eson the Searcher] publish_address {127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}

So the part you need is 127.0.0.1:9200, which should be equivalent to the default in kibana.yml:

# elasticsearch.url: "http://localhost:9200"

There is plenty of documentation available how publish_address / bound_adresses work in elasticsearch. There is no difference between windows and linux.

Ok, so where will this code be put? In the kibana or in the Elasticsearch config?

     # elasticsearch.url: "http://localhost:9200"

Also, I saw how to edit the cluster name, the node.name, and the network host address from a video by Zachary Tong.

  what components apply to these changes in version 2.1.0?  

  The video was on Elasticsearch 1.6.0

In Elasticsearch 2.1.0. you cannot find that code you told me to find so am confused.

In my Elasticsearch-2.1.0, what I found did not have what you told me to look for. What I found was this:

 # ---------------------------------- Network -----------------------------------
 #
 # Set the bind address to a specific IP (IPv4 or IPv6):
 #
 # network.host: 192.168.0.1
 #
 # Set a custom port for HTTP:
 #
 # http.port: 9200

You are looking at elasticsearch/config/elasticsearch.yml, but asked question about kibana/config/kibana.yml.

To summarize, the default config should be fine. Lines beginning with # are comments and unused.

Point your browser to http://localhost:5601 and Kibana should fire up.

If you change the setting network.host in elasticsearch.yml, you will need to adapt kibana.yml accordingly.

Be aware that network.host setting has changed very much from 1.6 to 2.1 (see https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking_20_network_changes.html). There is also plenty of discussion about this fact in this forum, e.g. ES 2.1 only bind on localhost or Connectivity issues with a new/upgraded 2.X cluster? Read here first :) (this one is even pinned at the top :innocent:)

I am getting this error from the Kibana app settings:

    Index Patterns 
    
  


    
        Warning No default index pattern. You must select or create one to continue.

Hi @nqioweryuadfge,

Please note that all conversations on this discussion forum are governed by Elastic's Community Code of Conduct. I encourage you to read through this entire document, but I'll specifically call your attention to this point:

Be patient. This mostly applies to forums, mailing lists, and code contributions (i.e. asynchronous forms of communication). Communities are often built on volunteer time both from participants and organizers. It is possible that your question or code contribution or suggestion might not receive an immediate response. Be patient and consider the norms of the community. One reminder ping is welcome, many reminder pings in rapid succession are not a good display of patience.

Thanks!

I have read through your documentation, but it doesn't explain how to solve a problem clearly. Do you think I would send hours waiting for an answer in this forum while I can find an answer online?

Check this first, and tell me what answer it has provided on how to solve the following problem from the following documentation:

 https://www.elastic.co/guide/en/kibana/current/settings.html

 Warning No default index pattern. You must select or create one to continue.
    

 INFO: Could not find files for the given pattern(s).

Did you index anything in elasticsearch ?

From the configuration file? I don't know how to do it. Tried to use the content online but not successful. I use 2.1.0. version. Please help on how it is done.

My text file is very large, and is delimited with two columns like the following:

badwords|goodwords

Do you have any idea of what you are doing?

I'd really recommend that you read the entire first chapter of the official guide here: https://www.elastic.co/guide/en/elasticsearch/guide/current/intro.html

Then, when you know what is elasticsearch and how to use it, start index some contents.
When done, start with Kibana.

Also there are a lot of resources on this website.
For example this one: https://www.elastic.co/webinars/get-started-with-elasticsearch/?baymax=default&elektra=docs&storm=top-video

We will be happy to help you once you have a better idea of what you can do and how.

Finally, follow the help part: https://www.elastic.co/help/

It gives some advices on how to ask questions.

2 Likes

Thanks nice time!