Marvel installed in elasticsearch client node, it complains "No Marvel Data Found"


#1

The elasticsearch version I am using is 2.3.
I just installed an elasticsearch cluster with 3 nodes,1 Master and data node, another data node, and a client node.
And I installed marvel in the client node.
It complains:

Do I need to install Marvel in Elasticsearch Master node ?


(Joe Fleming) #2

It sounds like you haven't installed Marvel on the Elasticsearch side. You need both for it to work correctly.

See the installation instructions

EDIT: Note that you'll need to install Marvel on all the nodes in your cluster. See the getting started docs for more information.


(Dfaropennetwork) #3

Hi Joe, i've the same issue but i've the marvel installed on elasticsearch and kibana with registred license.

var/www/kibana$ sudo bin/kibana plugin --list
-marvel

/var/www/kibana$ bin/kibana plugin --list
- readonlyrest
- marvel-agent
- license


(Joe Fleming) #4

Do you have the server component installed? You should see marvel in this list:

/path/to/elasticsearch$ bin/plugin list
Installed plugins in /path/to/elasticsearch/plugins
   - marvel

(Dfaropennetwork) #5

Yes yes I was confused with my last post sorry:

@:/usr/share/elasticsearch$ bin/plugin list
Installed plugins in /usr/share/elasticsearch/plugins:
- readonlyrest
- marvel-agent
- license


(Joe Fleming) #6

It's OK, I got the name of the marvel-agent plugin wrong anyway ;). I probably should have figured that out from the context of the output.

I'm guessing you only have the single node then, and that it's the same node that you are pointing Kibana at. Do you see the marvel indices in your cluster? Assuming you're using the default indices:

http://localhost:9200/.marvel-es-data-1/_search

http://localhost:9200/.marvel-es-*/_search

Also, check the time on your server and make sure it lines up with the time in your browser. If it's more than 10 minutes apart, you'll see the no data error.


(Dfaropennetwork) #7

Ok i will thanks so much.


#8

Just going to leave this here just in case anyone is as stupid as me...

I too had this problem, twice in fact. The first time, the times on the nodes we out. FW rule to the NTP server was the culprit. The second occasion was a script that was supposed to update just one index, updated all:

put _settings/index.refresh_interval=-1

Fixed it by updating them all back with:

put _settings/index.refresh_interval=1s


(Hubo3085632) #9

does your marvel'server time same with es client'time?


(yuji) #10

I had the same problem.
In my case, i defined custom path for plugins in elasticsearch.yml config file with: "path.plugins" property.

Custom config path must be given as parameter to plugin command with es.path.conf parameter:
https://www.elastic.co/guide/en/elasticsearch/plugins/current/_other_command_line_parameters.html


(David McClain) #11

Same problem here.
Wanted to put my resolution in as well for anyone else.

Check your license. Marvel installs with 30 days free. On top of that you can keep it free for a year at a time. If your license is expired you'll see no Marvel data as well as information in the cluster log telling you (telling me) exactly what the issue was.

--Edit--
Here's the URL: https://www.elastic.co/guide/en/marvel/current/license-management.html


(system) #12