Trouble setting up marvel 2.1.1 with elasticsearch 2.1.1

monitoring

(photonic_world) #1

Hi,

I am trying to setup marvel and kibana in the separate monitoring cluster with the following settings:

Referred ES documentation here: Installing marvel

  • Installed marvel-agent and license on my data+master nodes (restarted after the settings were made)
    excerpt of elasticsearch.yml in my elasticsearch data+master nodes is as below

cluster.name: elasticsearch1 node.data: true node.master: true marvel.agent.enabled: true marvel.agent.exporters.es.type: http marvel.agent.exporters.es.host: ["http://marvel-host:9200"] marvel.enabled: false
where id in the exporters is es

  • Created a monitoring cluster with hostname : marvel-host
    • Installed kibana following getting started guide here
    • Verified that kibana was up (kibana points to elasticsearch in the monitoring cluster, marvel-host:9200)
    • Installed marvel plugin for kibana
      bin/kibana plugin --install elasticsearch/marvel/latest
    • I could see marvel tab in the kibana dashboard.

The problem is I don't see my elasticsearch cluster. I seem to be missing something, but above is the exact procedure as described in the Elasticsearch documentation.

With ES & marvel 1.x, marvel had to be installed in the marvel monitoring cluster as well, is it the same here, should I install marvel as plugin for elasticsearch in the monitoring cluster?

Any help is greatly appreciated.

[Edit: I also do not see .marvel-es-data* index in my monitoring elasticsearch]

[Update: I see below in kibana logs, but I dont see .marvel-es-data index]
log [05:26:58.520] [info][status][plugin:elasticsearch] Status changed from red to green - Kibana index ready log [05:26:58.574] [info][status][plugin:marvel] Status changed from yellow to green - Marvel index ready log [05:27:01.108] [debug][plugin] Checking Elasticsearch version
Thanks,
Photon


(Mark Walkom) #2

That's wrong, you appear to have two : in there.


(photonic_world) #3

Apologize for the mistake. It is set properly with . in the yml file


(Mark Walkom) #4

Ok, the docs also state;

marvel.agent.exporters:

  id1:
    type: http
    host: ["http://es-mon-1:9200", "http://es-mon2:9200"]

But you only have marvel.agent.exporters.<random_id>:host:.


(photonic_world) #5

I didn't think type was important to show but yes it is set
marvel.agent.exporters.es.host: ["http://marvel-host:9200"] marvel.agent.exporters.es.type: http


(Mark Walkom) #6

Ok, so what do the main ES cluster's logs show?


(photonic_world) #7

In one of the nodes named 'cluster-host1'. I see
[2016-01-05 03:39:46,123][INFO ][node ] [cluster-host1] version[2.1.1], pid[1801], build[40e2c53/2015-12-15T13:05:55Z] [2016-01-05 03:39:46,123][INFO ][node ] [cluster-host1] initializing ... [2016-01-05 03:39:46,498][INFO ][plugins ] [cluster-host1] loaded [license, marvel-agent, mapper-murmur3], sites []

But I don't see it reporting data.. I have enabled debug logs for marvel as
logger: marvel: DEBUG

I am using kibana 4.3.1


(photonic_world) #8

Any leads to what

  • I should look for in the logs and make sure reporting from marvel agent is enabled?
  • Looks like kibana has created .kibana index, just that marvel plugin for kibana is not working? Any way I can confirm this?

(photonic_world) #9

OK found the issue, I used to use marvel.enabled on my cluster nodes with previous elasticsearch version, which would disable marvel reporting/creating data in the instance itself.

Setting this disabled marvel from reporting data and so was not working. .. Phew.. talk about self inflicted wounds.


(Tanguy) #10

I come after the war but thanks for letting us know :slight_smile:


(system) #11