How does Logstash integrate with Shield?


(Leslie Hawthorn) #1

Logstash 1.5 RC1 (or above) is required for Shield integration.

Logstash provides Elasticsearch plugins used to index and retrieve documents through HTTP, transport or client node protocols. These plugins support authentication against Elasticsearch and optionally data encryption between Logstash and Elasticsearch. Note that when using the Logstash elasticsearch output, only transport and http protocols are supported (node protocol is unsupported).

For details, please refer to the related documentation.


(system) #2