How my config file should be on publish mode with a single node?

Hello,

I'm trying to setup Elasticsearch on our porduction server. Initially, we'll use only one server, which means we'll have only one node. But I couldn't figure out how the configuration should be on a production server with a single node. I've tried some combinations which I described here but no luck.

So basically, can you give me an example for the yml configuration file for publish mode with a single node?

Thanks.

Should be ok with:

network.host: 0.0.0.0

Hi @dadoonet and thanks for helping. When I set the network host only it says:
[2019-07-05T14:10:52,582][INFO ][o.e.b.BootstrapChecks ] [] bound or publishing to a non-loopback address, enforcing bootstrap checks
and
[2019-07-05T14:10:52,598][ERROR][o.e.b.Bootstrap ] [] node validation exception [1] bootstrap checks failed [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
in the log file.

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

Hi,

I've read that wiki page before and I've set discovery.type to single-node but then it said:

cannot start with [discovery.type] set to [single-node] when local node does not have quorum in voting configuration VotingConfiguration

We've lost two weeks already.

This means that this node previously was part of a larger cluster, and doesn't necessarily have the latest cluster state, so can't become a one-node cluster since that would risk losing data. You'll need to join it back to the larger cluster and then follow the instructions for removing half or more of the master-eligible nodes so that you end up in a position where this node is certain to have the latest cluster state.

1 Like

Hi David and thanks for the fast reply.
Actually I don't understand, I've just installed the Elasticsearch and tried to run the service. I didn't create another cluster before. I don't have any data in that server, I just want to run the Elasticsearch service which I installed recently. My config file is so basic:

path.data: C:\ProgramData\Elastic\Elasticsearch\data
path.logs: C:\ProgramData\Elastic\Elasticsearch\logs
discovery.type: single-node

Can you share the logs from this node from when it starts until it emits the local node does not have quorum message? Also you've deleted something from this message, I think, but the thing that you've deleted is important, so could you put it back?

Full Log File:

[2019-07-08T10:52:03,376][INFO ][o.e.n.Node               ] [ServerNameHere] node name [ServerNameHere], node ID [S1tdE5hQTCeXwElJUyqBXw], cluster name [elasticsearch]
...
[2019-07-08T10:52:25,925][INFO ][o.e.c.c.Coordinator      ] [ServerNameHere] cluster UUID [W8qXkNWnSlab2CavcJNFQw]
...
[2019-07-08T10:52:25,932][ERROR][o.e.b.Bootstrap          ] [ServerNameHere] Exception
java.lang.IllegalStateException: cannot start with [discovery.type] set to [single-node] when local node {ServerNameHere}{S1tdE5hQTCeXwElJUyqBXw}{eGTcEUv2RuqfOhlGv-WOUA}{127.0.0.1}{127.0.0.1:9300}{ml.machine_memory=17179398144, xpack.installed=true, ml.max_open_jobs=20} does not have quorum in voting configuration VotingConfiguration{Q7UjKuM3QimcL4pCKmUB6w}

Yes, this node has definitely belonged to a cluster previously, and there was at least one other node with node ID Q7UjKuM3QimcL4pCKmUB6w in this cluster. That's not this node, because this node's unique ID is S1tdE5hQTCeXwElJUyqBXw instead.

If there's no data in this node then the simplest thing to do is delete the contents of C:\ProgramData\Elastic\Elasticsearch\data and let it start again from scratch.

1 Like

Yes, finally :grinning:

Deleting the data has solved my problem! Thank you very much David, I'm grateful.

1 Like

Hey,
I am also having problems with my single node, I built elasticsearch on a test machine
i started configuring the security,enabled xpach and discovery type to single node.
When i try to set the built-in users i get

so then i tried this:

Does anyone know whats my problem?
When i tried to configure the passwords without the discovery.type single node it did allow me, but i need the discovery.type
Thanks

Hi @Jeniffer, that looks like an unrelated issue, I suggest you open another thread about it. Also please don't post screenshots of text, they're difficult to search and are unreadable to those of us using screen-readers.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.