How should I disable the security manager?


(Kelly Davis) #1

Hopefully a simple question...

Tried to disable security manager according to the javadoc in the Security class.
Tried setting env variables using ES_JAVA_OPTS with or without the es prefix.
Tried configuring in elasticsearch.yml.

I also see a command line option '--security.manager.enabled'.

Note that I am running ES using the 5.1.1 docker image.

Thanks, Kelly


(Jason Tedor) #2

You can not disable the security manager starting in version 5.0.0. I will fix the Javadocs to reflect this change.

Would you mind explaining why you would like to disable the security manager, perhaps I can help?


(Kelly Davis) #3

Hey, thanks for your reply.. Please see this other question for an explanation: https://discuss.elastic.co/t/how-to-customize-plugin-security-policy-for-custom-realm/ as to why I wanted to turn it off. Looks like I do have a resolution for that issue, so don't need to disable it now. I didn't spend a lot of time searching for an answer to this question, so it would be nice if the docs were real explicit that it was not possible. Thanks again! Kelly


(Jason Tedor) #4

Okay, good, I was hoping that it would be something like this and we could just point you in the right direction. I see that @jaymode helped you there, and that's great.

I pushed a commit earlier this evening removing the language from the Javadocs saying that disabling the security manager is possible.

You're very welcome.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.