How to avoid IndexNotExits exception


(潘飞) #1

curl -XPOST 'localhost:9200/index1,index2,index3/_search -d '
{...}
'

if any index of the specified indexes does not exist, elasticsearch will
raise an error. is there any settings parameter to make it just omit the
missing indexes ?

Thanks !

--
不学习,不知道

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLCRJftRDsjms6STCR%2BSJWKUjjmMieYY2XqhoFTpp%2Bz6NA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(vineeth mohan-2) #2

Hello Panfei ,

Can you try this ignore_unavailable -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/multi-index.html#multi-index

Thanks
Vineeth

On Thu, Aug 28, 2014 at 2:38 PM, panfei cnweike@gmail.com wrote:

curl -XPOST 'localhost:9200/index1,index2,index3/_search -d '
{...}
'

if any index of the specified indexes does not exist, elasticsearch will
raise an error. is there any settings parameter to make it just omit the
missing indexes ?

Thanks !

--
不学习,不知道

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLCRJftRDsjms6STCR%2BSJWKUjjmMieYY2XqhoFTpp%2Bz6NA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLCRJftRDsjms6STCR%2BSJWKUjjmMieYY2XqhoFTpp%2Bz6NA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5msAZ77kV4pQrkLb6rgGCqNBrGnPhb6%3DRonZ0q%2Bujtgag%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(潘飞) #3

Hi vineeth, this helps us a lot , thanks very much !

2014-08-28 19:43 GMT+08:00 vineeth mohan vm.vineethmohan@gmail.com:

Hello Panfei ,

Can you try this ignore_unavailable -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/multi-index.html#multi-index

Thanks
Vineeth

On Thu, Aug 28, 2014 at 2:38 PM, panfei cnweike@gmail.com wrote:

curl -XPOST 'localhost:9200/index1,index2,index3/_search -d '
{...}
'

if any index of the specified indexes does not exist, elasticsearch will
raise an error. is there any settings parameter to make it just omit the
missing indexes ?

Thanks !

--
不学习,不知道

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLCRJftRDsjms6STCR%2BSJWKUjjmMieYY2XqhoFTpp%2Bz6NA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLCRJftRDsjms6STCR%2BSJWKUjjmMieYY2XqhoFTpp%2Bz6NA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5msAZ77kV4pQrkLb6rgGCqNBrGnPhb6%3DRonZ0q%2Bujtgag%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5msAZ77kV4pQrkLb6rgGCqNBrGnPhb6%3DRonZ0q%2Bujtgag%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
不学习,不知道

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CA%2BJstLAqK3WoDAFLKKZysOM_AWrUtwKNNY9J8qo20kMcz5ZzNg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4