How to change max payload size on cloud Kibana

I am trying to use filebeat to send logs to elastic cloud, however on calling "filebeat setup" I get the following error:

Response: {"statusCode":413,"error":"Request Entity Too Large","message":"Payload content length greater than maximum allowed: 1048576"}

I can't find the max payload setting in the UI for Kibana, is there a way of changing it?

Check the guide here, you can edit the deployment and set custom setting for Kibana instance
NB: I don't see the custom setting for what you are looking for as on perm

server.maxPayloadBytes: 1048576

It's the same for self managed.

About halfway down on this page

@harmanpa @ylasri Ahhh to be clear... It is configurable in cloud it is just undocumented ... or perhaps a bug in the docs. I just tested it. Don't set it tooo large.

There is a little caveat in the Elasticsearch service docs

"If a setting is not supported by Elasticsearch Service, you will get an error message when you try to save."

This is after I applied the change, change applied and I opened up the kabana.yml again it is there, that is how you know it took.

Thank you both, I can confirm that it does indeed work and fix the problem!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.