How to control maximum number of client connections to ES instance


(Ramdev Wudali) #1

Hi:
Is there a configuration variable that I could set on an ES instance
that can control the maximum number of client connections ? What is the
default limit on the max. connections ? and how can I change it ?

If I have a SPARK application that is retrieving results from an ES
instance, I am running into a NoNodeAvailable Exception. But if I reduce
the number of processes, then the errors seems to go away.
all help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

There are thread pools which is probably what you are hitting -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-threadpool.html#modules-threadpool

On 3 December 2014 at 14:06, Ramdev Wudali agastya71@gmail.com wrote:

Hi:
Is there a configuration variable that I could set on an ES instance
that can control the maximum number of client connections ? What is the
default limit on the max. connections ? and how can I change it ?

If I have a SPARK application that is retrieving results from an ES
instance, I am running into a NoNodeAvailable Exception. But if I reduce
the number of processes, then the errors seems to go away.
all help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X95A13-XRNOvZGh9gPFqhm%2BpvwAXiHoa_GT173Rgwwtkw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #3

There is no limit on the number of client connections imposed by ES.

If you see NoNodeAvailableException you may have hit a connect timeout of
the client. Connect timeout is 30 secs IIRC.

Jörg

On Wed, Dec 3, 2014 at 4:06 AM, Ramdev Wudali agastya71@gmail.com wrote:

Hi:
Is there a configuration variable that I could set on an ES instance
that can control the maximum number of client connections ? What is the
default limit on the max. connections ? and how can I change it ?

If I have a SPARK application that is retrieving results from an ES
instance, I am running into a NoNodeAvailable Exception. But if I reduce
the number of processes, then the errors seems to go away.
all help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGc0Yvrk8MBje0Zpq9DyvrpG8Od%2BeUKUNWwiXPfDq_XJw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ramdev Wudali) #4

Hi Jorg:
can the Transport settings be changed on the fly (using curl -XPUT )?
If so, what is the command ?

(I doubt its a cluster setting (it is not mentioned on the cluster settings
page of the documentation))

Thanks for the assist

Ramdev

On Wed, Dec 3, 2014 at 5:46 AM, joergprante@gmail.com <joergprante@gmail.com

wrote:

There is no limit on the number of client connections imposed by ES.

If you see NoNodeAvailableException you may have hit a connect timeout of
the client. Connect timeout is 30 secs IIRC.

Jörg

On Wed, Dec 3, 2014 at 4:06 AM, Ramdev Wudali agastya71@gmail.com wrote:

Hi:
Is there a configuration variable that I could set on an ES instance
that can control the maximum number of client connections ? What is the
default limit on the max. connections ? and how can I change it ?

If I have a SPARK application that is retrieving results from an ES
instance, I am running into a NoNodeAvailable Exception. But if I reduce
the number of processes, then the errors seems to go away.
all help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0f2f4642-f670-418d-9e6d-32039483af9f%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/VyNpCs17aTA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGc0Yvrk8MBje0Zpq9DyvrpG8Od%2BeUKUNWwiXPfDq_XJw%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGc0Yvrk8MBje0Zpq9DyvrpG8Od%2BeUKUNWwiXPfDq_XJw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gUMXULy_dRhLmn0wAFZjHmfzosX8D1qvH%2BaVvT95hFkQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Dmitry Goldenberg) #5

Could someone state whether there was a resolution and a problem cause figured out? Thanks.


(system) #6