How to display Panels in Kibana from different Indices?


(Vikas Gopal) #1

I have 2 indices av1 and av2 , in Kibana I am merging both the indices into one like av*. With this approach I got 100 fields (50 each index). Now I want to create dashboard which will have multiple panels , some of the panels field are from av1 index and some are from av2 index . Can someone suggest how I can show data in all the panes without having a dependency on the specific index ?


(Peter Pisljar) #2

maybe i got this wrong, but why don't you create two index patterns (av1 and av2), create some visualizations on av1 some on av2 and then add them all to one dashboard ?


(Vikas Gopal) #3

Hi Peter ,
Thanks for the response , I am aware that I can do what you suggested but this will not solve my purpose because if I click on any panel which is lets say build on av1 then all av2 panels will be blank which I do not want .

Just to achieve this I merged two indices into one as I saw lots of suggestion on this , problem is with the filter . If I apply any filter it again becomes specific to one of the index .I am also aware to resolve this I need to use the common keyword between all indices , but this is not easy in my case.

Hope I am clear , any thoughts or suggestions would really appreciated


(Peter Pisljar) #4

unfortunately i am not aware of any workaround for this .... maybe @Bargs has some suggestions ?


(Matt Bargar) #5

It sounds like you need to enable courier:ignoreFilterIfFieldNotInIndex in Advanced Settings.


(Vikas Gopal) #6

@Bargs thank you for the prompt response here is the screen shot that I captured from my dashboard , so I have set the advance property that you suggest , still my second panel is blank if I apply filter on my 3rd panel that is pie chart.

Total Device and Pie chart these are coming from av1 index and infected number is from av2 index . Now when I apply filter like Severs my infected visualization says no result found .


(Vikas Gopal) #7

I see, since my visualizations are on index alias causes the problem , well I see the significance of having courier:ignoreFilterIfFieldNotInIndex to true so, it will skip those visualizations if the field does not exist in the respective Index . But if we want the default behavior then we need to map/merge everything in one index . Please correct me if I am wrong ?


(Matt Bargar) #8

That's correct, unfortunately courier:ignoreFilterIfFieldNotInIndex is a global setting at the moment so it can't be applied conditionally to one panel and not another. We've been having some discussions about how to improve this setting and filtering on multi index dashboards in general, if you have any ideas or could share more about your use case please join in on the Github issue: https://github.com/elastic/kibana/issues/14081


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.