How to fix cluster health yellow with Elastic Search


(James Crone) #1

Hello.!

  Elastic search stuck in yellow status. I searched a lot about this 

problem and i find out same answer that to create two nodes. So i create
two nodes by creating two config file elasticsearch.yml and
elasticsearch-1.yml and start by command:

elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch.yml
elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch-1.yml

Run this command Separately.

first time its return green status. when i restarted again it shows again
that:

{
"cluster_name" : "alterduden",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 29,
"active_shards" : 29,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

I am also trying to allocating shards but i failed this is necessary to
create new index if i have to define shards? Or what should i do to fix
this to green ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

First this is not a problem. Just showing you that all primaries are allocated but nor replicas.

How to solve it?

Increase the number of nodes. Obviously elasticsearch doesn’t replicate on the same node
or
Reduce the number of replicas (you can do it live)
or
Live with it

Now coming back to the fact that you are trying to start a new node, the output you printed shows that you have only one node running.

"number_of_nodes" : 1,

Note that to run another node, you are not forced to define a new elasticsearch.yml file.

So running bin/elasticearch might be enough.

Not enough information to say more for now.

--
David Pilato - Developer | Evangelist
elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 10:50, James Crone arafay696@gmail.com a écrit :

Hello.!

  Elastic search stuck in yellow status. I searched a lot about this problem and i find out same answer that to create two nodes. So i create two nodes by creating two config file elasticsearch.yml and elasticsearch-1.yml and start by command: 

elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch.yml
elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch-1.yml

Run this command Separately.

first time its return green status. when i restarted again it shows again that:

{
"cluster_name" : "alterduden",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 29,
"active_shards" : 29,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

I am also trying to allocating shards but i failed this is necessary to create new index if i have to define shards? Or what should i do to fix this to green ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8F4A852F-5C28-4494-9CE4-EEC1AF3EEB0E%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(James Crone) #3

Thanks for your quick reply.
Two nodes is necessary for this issue?
And Can i define two nodes in single config file like:
node:
name: firstnode
name: secondnode
? and just start by bin/elasticsearch

On Thursday, April 30, 2015 at 2:12:22 PM UTC+5, David Pilato wrote:

First this is not a problem. Just showing you that all primaries are
allocated but nor replicas.

How to solve it?

Increase the number of nodes. Obviously elasticsearch doesn’t replicate on
the same node
or
Reduce the number of replicas (you can do it live)
or
Live with it

Now coming back to the fact that you are trying to start a new node, the
output you printed shows that you have only one node running.

  • "number_of_nodes" : 1,*

Note that to run another node, you are not forced to define a new
elasticsearch.yml file.

So running bin/elasticearch might be enough.

Not enough information to say more for now.

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 10:50, James Crone <araf...@gmail.com <javascript:>> a
écrit :

Hello.!

  Elastic search stuck in yellow status. I searched a lot about this 

problem and i find out same answer that to create two nodes. So i create
two nodes by creating two config file elasticsearch.yml and
elasticsearch-1.yml and start by command:

elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch.yml
elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch-1.yml

Run this command Separately.

first time its return green status. when i restarted again it shows again
that:

{
"cluster_name" : "alterduden",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 29,
"active_shards" : 29,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

I am also trying to allocating shards but i failed this is necessary to
create new index if i have to define shards? Or what should i do to fix
this to green ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbab7954-5e45-4904-a60d-bcb3c1377f49%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

As I said, it’s not an issue. Your cluster is working well.
But if you want to allocate one replica for each primary shard, you will need one more node.
If you set number of replica to 2, your cluster will be yellow again until you start a new node.

If you really want to change the node name, you can also set it using for the first node

bin/elasticsearch --node.name firstnode

and this for the second

bin/elasticsearch --node.name secondnode

I said "If you really want to change the node name" because I guess that you are doing tests on your local machine.
So you basically don’t need to do that.
If your plan is to do that in production, please don’t! Don’t run more than one node per machine unless you have more than 64gb RAM.

--
David Pilato - Developer | Evangelist
elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 11:22, James Crone arafay696@gmail.com a écrit :

Thanks for your quick reply.
Two nodes is necessary for this issue?
And Can i define two nodes in single config file like:
node:
name: firstnode
name: secondnode
? and just start by bin/elasticsearch

On Thursday, April 30, 2015 at 2:12:22 PM UTC+5, David Pilato wrote:
First this is not a problem. Just showing you that all primaries are allocated but nor replicas.

How to solve it?

Increase the number of nodes. Obviously elasticsearch doesn’t replicate on the same node
or
Reduce the number of replicas (you can do it live)
or
Live with it

Now coming back to the fact that you are trying to start a new node, the output you printed shows that you have only one node running.

"number_of_nodes" : 1,

Note that to run another node, you are not forced to define a new elasticsearch.yml file.

So running bin/elasticearch might be enough.

Not enough information to say more for now.

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co/
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 10:50, James Crone <araf...@ <>gmail.com http://gmail.com/> a écrit :

Hello.!

  Elastic search stuck in yellow status. I searched a lot about this problem and i find out same answer that to create two nodes. So i create two nodes by creating two config file elasticsearch.yml and elasticsearch-1.yml and start by command: 

elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch.yml
elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch-1.yml

Run this command Separately.

first time its return green status. when i restarted again it shows again that:

{
"cluster_name" : "alterduden",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 29,
"active_shards" : 29,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

I am also trying to allocating shards but i failed this is necessary to create new index if i have to define shards? Or what should i do to fix this to green ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@ <>googlegroups.com http://googlegroups.com/.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbab7954-5e45-4904-a60d-bcb3c1377f49%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/dbab7954-5e45-4904-a60d-bcb3c1377f49%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E9BCEBC0-B8E5-4DD7-B4C9-82C0751748F3%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(James Crone) #5

Ok i understand. Thanks Pilato

On Thursday, April 30, 2015 at 3:38:47 PM UTC+5, David Pilato wrote:

As I said, it’s not an issue. Your cluster is working well.
But if you want to allocate one replica for each primary shard, you will
need one more node.
If you set number of replica to 2, your cluster will be yellow again until
you start a new node.

If you really want to change the node name, you can also set it using for
the first node

bin/elasticsearch --node.name firstnode

and this for the second

bin/elasticsearch --node.name secondnode

I said "If you really want to change the node name" because I guess that
you are doing tests on your local machine.
So you basically don’t need to do that.
If your plan is to do that in production, please don’t! Don’t run more
than one node per machine unless you have more than 64gb RAM.

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 11:22, James Crone <araf...@gmail.com <javascript:>> a
écrit :

Thanks for your quick reply.
Two nodes is necessary for this issue?
And Can i define two nodes in single config file like:
node:
name: firstnode
name: secondnode
? and just start by bin/elasticsearch

On Thursday, April 30, 2015 at 2:12:22 PM UTC+5, David Pilato wrote:

First this is not a problem. Just showing you that all primaries are
allocated but nor replicas.

How to solve it?

Increase the number of nodes. Obviously elasticsearch doesn’t replicate
on the same node
or
Reduce the number of replicas (you can do it live)
or
Live with it

Now coming back to the fact that you are trying to start a new node, the
output you printed shows that you have only one node running.

  • "number_of_nodes" : 1,*

Note that to run another node, you are not forced to define a new
elasticsearch.yml file.

So running bin/elasticearch might be enough.

Not enough information to say more for now.

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co/
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 30 avr. 2015 à 10:50, James Crone araf...@gmail.com a écrit :

Hello.!

  Elastic search stuck in yellow status. I searched a lot about this 

problem and i find out same answer that to create two nodes. So i create
two nodes by creating two config file elasticsearch.yml and
elasticsearch-1.yml and start by command:

elasticsearch -Des.config=d:/elasticsearch-1.5.0/config/elasticsearch.yml
elasticsearch
-Des.config=d:/elasticsearch-1.5.0/config/elasticsearch-1.yml

Run this command Separately.

first time its return green status. when i restarted again it shows again
that:

{
"cluster_name" : "alterduden",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 29,
"active_shards" : 29,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

I am also trying to allocating shards but i failed this is necessary to
create new index if i have to define shards? Or what should i do to fix
this to green ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/cc7f3fcc-3dc8-44ec-a925-ccfc54fc5e03%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dbab7954-5e45-4904-a60d-bcb3c1377f49%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/dbab7954-5e45-4904-a60d-bcb3c1377f49%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/702a23b9-1681-4b6d-9f01-ba2aef3f5363%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6