How to increase replicas for .kibana index

Hi Team,

In my cluster, I've found that by default every new index created with 1 shard and 1 replica; So I also changed default settings with 2 primary and 2 replica successfully for every new indices, which was found working properly later.

However, I’ve ended up with already got created .kibana index with 1 shard and 1 replica. So I tried to increase its replicas by using API calls as shown below.

    PUT /.kibana/_settings
    {
      "index" : {
        "number_of_replicas" : 3
      }
    }

Issue definition: I am not able to increase its replicas while increasing its replicas to 3 even through already acknowledged through API.

Any help here will be much appreciated.

What happens after you run that request?

it shows acknowledged.

{
  "acknowledged" : true
}

Ok, but how do you know it doesn't work?

I found that replicas are not increasing for .kibana index even though applying this command. Do I need to add/troubleshoot something ?

Check the index settings. I wonder if the Kibana index does not use auto_expand_replicas, which would override the number_of_replicas setting.

1 Like

AFAIK it does use auto-expand, most of the system indices do.

1 Like

Thank you so much @Christian_Dahlqvist @warkolm for your quick assistance over here. I appreciate your help and time.

I found that .kibana index replicas are shown increased now.

For the people who want the API call, I would like to add it here.


PUT /.kibana/_settings
{
  "index" : {
    "auto_expand_replicas" : "0-all"
  }
}

Reference Link

1 Like