How to install logstash-integration-jdbc plugin

I'm trying to install logstash-integration-jdbc following this git logstash-integration-jdbc
running logstash 7.12.1

I've installed jruby

 $ jruby --version
jruby (2.3.3) 2020-02-29 fffffff OpenJDK 64-Bit Server VM 11.0.11+9-Ubuntu-0ubuntu2.20.04 on 11.0.11+9-Ubuntu-0ubuntu2.20.04 +jit [linux-x86_64]

and bundler gem

$ ruby -S gem list --local

*** LOCAL GEMS ***

bundler (2.2.19)
bundler-unload (1.0.2)
cmath (default: 1.0.0)
csv (default: 1.0.0)
did_you_mean (1.2.0)
executable-hooks (1.6.1)
fileutils (default: 1.1.0)
gem-wrappers (1.4.0)
ipaddr (default: 1.2.0)
jar-dependencies (default: 0.4.0)
jruby-launcher (1.1.17 java)
jruby-openssl (0.10.7 java, default: 0.10.2 java)
jruby-readline (default: 1.3.7 java)
json (default: 2.2.0 java)
minitest (5.10.3)
net-telnet (0.1.1)
power_assert (1.1.3)
psych (default: 3.1.0 java)
rake (13.0.3, 12.3.2)
rake-ant (default: 1.0.4)
rdoc (default: 6.1.2)
rubygems-bundler (1.4.5)
rvm (
scanf (default: 1.0.0)
test-unit (3.2.8)
webrick (default: 1.4.2)
xmlrpc (0.3.0)

I also done clone from the git source

$ ./gradlew vendor
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon:
Daemon will be stopped at the end of the build stopping after processing

2 actionable tasks: 2 executed

but when I try to install the bundle

$ bundle install
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Fetching gem metadata from
Resolving dependencies...........................................................
Bundler could not find compatible versions for gem "logstash-core":
  In Gemfile:
    logstash-integration-jdbc was resolved to 5.1.1, which depends on
logstash-core-plugin-api (>= 1.60, <= 2.99) was resolved to 1.60.1, which
depends on
        logstash-core (>= 2.4.0.snapshot1, <= 2.4.99)

    logstash-integration-jdbc was resolved to 5.1.1, which depends on
      logstash-core (>= 6.5.0)

What should I do now?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.