How to move ES data to another machine?


I am upgrading to a more efficient machine to run my ES on but I do not want to lose the data I have already stashed in my ES. Here is what I have tried so far:

1.) Node Exporter
In a command shell: node exporter.js -a myCurrentIPAddess -p 9201 -b myDestinationIPAddress -p 9200
(Note: my current ES is directed to 9201, however, I also tried this command after redirecting it to 9200)
Here was the output:

2.) Copying and Pasting ES
I tried to zip my current ES and copy and paste it in the new machine. In the elasticsearch.yml file I then changed the max number of nodes to 2. I was able to get both instances up and running but when I looked at the new ES on the new machine the data from my old ES was not there.

3.) Reindexing with Logstash:
here is my config file

here was the output

My goal is to create a new instance of ES on a new machine but send data from my current ES instance to it so it can be accessed in Kibana.

Thank you so much for your help!

You can do #2 but just start the new node as it's own cluster, don't try to join it to the original one.

Thank you for your reply, Mark!

I started fresh and made a new zip of my current ES and put it on my new machine. I changed the cluster name and made sure the host and port are correct, however, I got a seemingly endless error. I've pasted a portion of it below in hopes that it will be of some use.

Thank you for your help!

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them :slight_smile:

I apologize, here it is in text format.

[2017-04-04T08:54:11,302][WARN ][o.e.c.a.s.ShardStateAction] [TcLoggingNode1] [l
ogstash-2017.03.28][0] unexpected failure while sending request [internal:cluste
r/shard/failure] to [{TcLoggingNode1}{Dw7BwFbvQHSVM7MlEDTm1A}{TzGxQpvkT7mctfcbVu
6JaQ}{local}{local[1]}] for shard entry [shard id [[logstash-2017.03.28][0]], al
location id [8nQKkZwIRIOADaDQX0ErKg], primary term [0], message [failed recovery
], failure [RecoveryFailedException[[logstash-2017.03.28][0]: Recovery failed on
]}]; nested: IndexShardRecoveryException[failed to recover from gateway]; nested
: EngineCreationFailureException[failed to create engine]; nested: NoSuchFileExc
MCbIW1BB7qFSg\0\translog\translog-13.tlog]; ]]
org.elasticsearch.transport.SendRequestTransportException: [TcLoggingNode1][loca
        at org.elasticsearch.transport.TransportService.sendRequestInternal(Tran ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.transport.TransportService.sendRequest(TransportSer ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.transport.TransportService.sendRequest(TransportSer ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.cluster.action.shard.ShardStateAction.sendShardActi
on( ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.cluster.action.shard.ShardStateAction.shardFailed(S ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.cluster.action.shard.ShardStateAction.localShardFai
led( ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.indices.cluster.IndicesClusterStateService.sendFail
Shard( ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.indices.cluster.IndicesClusterStateService.failAndR
emoveShard( ~[elasticsearch-5.2.0.jar:5.2.0]

        at org.elasticsearch.indices.cluster.IndicesClusterStateService.handleRe
coveryFailure( ~[elasticsearch-5.2.0.jar:5.2
        at org.elasticsearch.indices.cluster.IndicesClusterStateService.access$8
00( ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.indices.cluster.IndicesClusterStateService$Recovery
Listener.onRecoveryFailure( ~[elasticsearch-
        at org.elasticsearch.index.shard.IndexShard.lambda$startRecovery$1(Index ~[elasticsearch-5.2.0.jar:5.2.0]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreserv ~[elasticsearch-5.2.0.jar:5.2.0]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:
        at java.util.concurrent.ThreadPoolExecutor$ Source) [?
        at Source) [?:1.8.0_111]Preformatted text
Caused by: org.elasticsearch.transport.TransportException: TransportService is c
losed stopped can't send request
        at org.elasticsearch.transport.TransportService.sendRequestInternal(Tran ~[elasticsearch-5.2.0.jar:5.2.0]
        ... 15 more

Thank you!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.