How to update rollover conditions for a lifecycle policy?

I have a metricbeat index ,metricbeat-7.9.1-2020.11.23-000001, and I would like to update the max size condition for the rollover action.

The response from /_ilm/explain :

 {
    "indices": {
        "metricbeat-7.9.1-2020.11.23-000001": {
            "index": "metricbeat-7.9.1-2020.11.23-000001",
            "managed": true,
            "policy": "metricbeat",
            "lifecycle_date_millis": 1606114916403,
            "age": "2.95h",
            "phase": "hot",
            "phase_time_millis": 1606114916623,
            "action": "rollover",
            "action_time_millis": 1606115276483,
            "step": "check-rollover-ready",
            "step_time_millis": 1606115276483,
            "phase_execution": {
                "policy": "metricbeat",
                "phase_definition": {
                    "min_age": "0ms",
                    "actions": {
                        "rollover": {
                            "max_size": "50gb",
                            "max_age": "30d"
                        }
                    }
                },
                "version": 1,
                "modified_date_in_millis": 1605970574710
            }
        }
    }
}

Currently the max_size is 50G. Where , if possible, on Kibana can I update the rollover conditions ?
I can only find the condition settings for the phase of the policy.

If this is not possible through the UI , is there a request that can achieve this ?

Hi @Kenn,

Kibana provides a UI to help you manage the existing ILM policies in your cluster in the Stack Management section

In this case, the policy you are looking for is metricbeat:

More info about this: https://www.elastic.co/guide/en/elasticsearch/reference/7.10/index-lifecycle-management.html

@afharo Thank you. I did already set the conditions there, yet it did not work.

What I did do to get it working was to force a rollover :

/:alias/_rollover/:index 

Seems like the old index was on a older version of the policy.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.