How to upgrade to 2.0 if meta-fields exist in mapping?


(FAGIM SADYKOV) #1

We see that it's possible with reindexing data with moving from 1.7 to 2.0 instance. But it sees not very efficient. How to upgrade to 2.0 efficiently if we already have indexes that stores _id and _version?


(Mark Walkom) #2

You need to reindex unfortunately.


(FAGIM SADYKOV) #3

So sad...
2.0 full of breaking changes, so migration on it is not simple for projects that uses ES for at least year...
While it's not good we see that we should stay on 1.7 for some meaning time...


(system) #4