How to use ES & es-hadoop 5.0 under java 1.7

(Brad Jungsu Heo) #1


I'm running my cluster with CDH 5.8 which provides jdk 1.7.0_67 (I can't upgrade at this moment)

I tried to use ES 5.0 & es-hadoop but I'm getting an error

java.lang.UnsupportedClassVersionError: org/elasticsearch/spark/rdd/CompatUtils : Unsupported major.minor version 52.0

According to this issue, it seems like a java version mis-match problem.

But the ES Hadoop 5.0 Requirements says that:

we strongly recommend using the latest JDK 8 (at least u20 or higher). If that is not an option, use JDK 7.0 update u55 (required for Elasticsearch 1.2 or higher).

So I'm wondering how can I use ES & es-hadoop 5.0 with Java 1.7


(Christian Dahlqvist) #2

While the ES-hadoop connector may not, Elasticsearch 5.0 requires Java 1.8. Java 1.7 is no longer supported.

(Brad Jungsu Heo) #3


Thank you for your reply.

Then what does this sentence mean?

If that is not an option, use JDK 7.0 update u55

exceprted from here

Thanks in advanced

(Christian Dahlqvist) #4

Elasticsearch 5.0 has a different requirement on Java version than the ES-Hadoop connector.

(James Baiera) #5

@Brad_Jungsu_Heo The ES-Hadoop major version for Scala classes is a bug. I've opened a github issue for it.

(Brad Jungsu Heo) #6




(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.