I dont see the records which has few missing values

Hi Team,
I have created data table, I could able to see the results only when the object has the value of all the column. If any of hte object does not have value of the column, then those records are not qualified for the results.
my requirement is to show records which has missing colums too. how to acheive that.

I see couple of options there while creating data table.

  1. "show missing values" option
  2. "show partial rows" option

attached screenshot for the results of both the options .

option 1 : I dont see any change in the table after selecting this one. still I see only records which has all the fields

optionn 2: by enabling "show partial rows" option I could see the count column for all my main column

let me know what needs to be done if I want to display all the records.

Hello @gobi_s

I might be missing something, it looks to me like you solved your problem by using the 'show partial rows' options. Keep in mind, you're also specifying a filter in the query bar and are only showing the last 15 minutes of documents.

Is there something I missed?


Hi Matt,
in the first screenshot, I was expecting few records ( all the records has one or two missing values) after enabling "Show missing values" . but I dont see any records over there.
If you look at the second screenshot, I have enabled the "show partial rows" options, now , I am getting records but the issue is I see metric column for each colum which I dont want. and I did not enable the "show bucket for every column".

Expectation is, display all the rows (object) that include missing columns.

ELK verison : 7.4.0

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.