I got errors after installing x-pack on elasticsearch 5.0.1 node: "exception when exporting documents"


#1

Hi !

I run an elasticsearch node in a Docker container (from the official docker image). All bootstrap checks are passing, everything works great without x-pack.

I followed the installation procedure (from here), but when I restart my node, I have the following error:

    [2016-11-24T14:25:17,169][INFO ][o.e.x.m.e.Exporters      ] [SR067974CTI3700] skipping exporter [default_local] as it isn't ready yet
[2016-11-24T14:25:17,169][ERROR][o.e.x.m.AgentService     ] [SR067974CTI3700] exception when exporting documents
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:188) ~[x-pack-5.0.1.jar:5.0.1]
        at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.0.1.jar:5.0.1]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]

These lines are thrown every 10 seconds.

When I try to do a get on localhost:9200 with curl, I got:

$ curl localhost:9200?pretty -u elastic:changeme
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "failed to authenticate user [elastic]",
        "header" : {
          "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "failed to authenticate user [elastic]",
    "header" : {
      "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
    }
  },
  "status" : 401
}

Any Idea?

Thanks!


(Lei Zhu) #2

I'm running into the same issue, any solution?


#3

Hey Everyone,

I'm seeing the exact same issue, but I'm not running ES in a docker container. ES version 5.1.1


(Joe Fleming) #4

Have you changed anything with your security settings? elastic:changeme should work out of the box.

Can you try to disabled Security and see if everything else is working correctly? You can disable it by adding xpack.security.enabled: false to your elasticsearch.yml.


#5

I made two changes, but not sure which one made the difference. During the upgrade I had disabled shard allocation. After upgrading and installing x-pack I wasn't able to re-enable shard allocation due to failed auth. The other thing I didn't do initially was step three in x-pack install guide. Once I removed x-pack, I re-enabled shard allocation and then added the action.auto_create_index line to my config file. I reinstalled x-pack and all is good now. Hope this helps anyone else out there.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.