Icu_normalizer is not working

here the Error message - when I'm trying to use icu_normalizer in my elastic search.
installed the plugins as well.
"error": {
"root_cause": [
"type": "illegal_argument_exception",
"reason": "Unknown filter type [icu_normalizer] for [nfc_normalizer]"
"type": "illegal_argument_exception",
"reason": "Unknown filter type [icu_normalizer] for [nfc_normalizer]"
"status": 400

What is the output of:

GET /_cat/plugins?v

output: name component version

@dadoonet And also I'm using kibana from there I queried this and got the output looks like above.

You did not show the output of the first call.
Anyway I believe you did not restart your nodes.

@dadoonet Sorry , here the first call output
"name": "SS22",
"cluster_name": "elasticsearch",
"cluster_uuid": "XFsxgmJhSEeRL4xjFMOlcw",
"version": {
"number": "6.4.2",
"build_flavor": "unknown",
"build_type": "unknown",
"build_hash": "04711c2",
"build_date": "2018-09-26T13:34:09.098244Z",
"build_snapshot": false,
"lucene_version": "7.4.0",
"minimum_wire_compatibility_version": "5.6.0",
"minimum_index_compatibility_version": "5.0.0"
"tagline": "You Know, for Search"

how can i restart the elastic search service...because it always running on port 9200

It depends on how you started it and what is your OS.

I have set up on the windows 7 machine.
Just installed the elastic search file and then configured as given in the official doc.
then started service by entering elasticsearch.
but DNW command for stopping the elastic search service.

I don't know windows but I suppose that if you go to "services" in the admin menu, you will see elasticsearch and you can stop it and start again...

Yes I got that...but my issue is not solved

did you have idea...why icu_normalizer is giving error

Once you have restarted, what is the output of:

GET /_cat/plugins?v

If empty, then you probably did not install the plugin well.

yes it is can i install plugins in good way
becoz I installed the plugin with the command elasticsearch-plugin install analysis-icu

Probably you need to change that:

But may be someone from the Microsoft team could help.

I have solved the issue by just killing the elastic search by using PID then I restarted the elastic search once again and installed the analyzer plugin.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.