If I search for more than 30days data getting the below error. Please advise where to change the "Search.max_buckets" value?

{
"request": {},
"response": {},
"body": {
"statusCode": 503,
"error": "Service Unavailable",
"message": "search_phase_execution_exception",
"attributes": {
"error": {
"root_cause": ,
"type": "search_phase_execution_exception",
"reason": "",
"phase": "fetch",
"grouped": true,
"failed_shards": ,
"caused_by": {
"type": "too_many_buckets_exception",
"reason": "Trying to create too many buckets. Must be less than or equal to: [65535] but was [65536]. This limit can be set by changing the [search.max_buckets] cluster level setting.",
"max_buckets": 65535
}
}
}
},
"name": "Error",
"req": {},
"res": {}
}

Hi @ARAVINTH !!

Look this annswer: elasticsearch - Elastic search aggregation query throwing exception - Stack Overflow

Thank you. Issue is fixed now.

1 Like

Welcome to our community @ARAVINTH! :smiley:

A few pointers for any future threads you open;

  • Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you
  • Please also don't just post a body of text/code/json with no other context.