I'm a beginner. I want to use elasticsearch with PostgreSQL

Hello,
first thank you to read me !
second I'm french and my english is very bad !
third I hope you can help me. I really want to use ES !!!!

So,
I want to use ES with postgreSQL. ES and postgreSQL are on the same server
(debian).
ES is running no problem. I'm using Elasticsearch head.

It's ok but status is yellow. Normal my cluster is Unassigned
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! And there's the default
cluster (I don't mind....)

There's no modification in elasticsearch.yml.

Connection with PostgreSQL : I have done this :

curl -XPUT 'localhost:920_river/my_jdbc_river/_meta' -d '{ "type" : "jdbc",
"jdbc" : { "driver" : "org.postgresql.Driver", "url" :
"jdbc:postgresql://localhost:5432/PMS", "user" : "postgres", "password" :
"postgres" }, "index" : { "index" : "jdbc", "type" : "jdbc" } }'
Result :
{"ok":true,"_index":"_river","_type":"my_jdbc_river","_id":"_meta","_version":1}

But if I redo this with bad user or password, result is the same
!!!!!!!!!!!!!!!!!

*Well,
*

  1. how to remove the default cluster ?
  2. how to connect ES with PostgreSQL ? What is wrong ?
  3. Please, please, please, please help !!!!!

Thank you very much everyone.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Welcome!

We (frenchies) are always saying "excuse for my french". That's how everyone know that we are french :wink:
About french question, you should be aware that there is also a french mailing list which should help you: elasticsearch-fr@googlegroups.com

Everything you did by now sounds ok.
Did you try to search after creating the river?
Can you see anything in logs?

Also, I don't understand what is a "Cluster" from your point of view? Are you talking about indexes?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 avr. 2013 à 17:03, eby eurogiciel eby.eurogiciel@gmail.com a écrit :

Hello,
first thank you to read me !
second I'm french and my english is very bad !
third I hope you can help me. I really want to use ES !!!!

So,
I want to use ES with postgreSQL. ES and postgreSQL are on the same server (debian).
ES is running no problem. I'm using Elasticsearch head.

It's ok but status is yellow. Normal my cluster is Unassigned !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! And there's the default cluster (I don't mind....)

There's no modification in elasticsearch.yml.

Connection with PostgreSQL : I have done this : https://github.com/jprante/elasticsearch-river-jdbc/wiki/Step-by-step-recipe-for-setting-up-the-river-with-PostgreSQL

curl -XPUT 'localhost:920_river/my_jdbc_river/_meta' -d '{ "type" : "jdbc", "jdbc" : { "driver" : "org.postgresql.Driver", "url" : "jdbc:postgresql://localhost:5432/PMS", "user" : "postgres", "password" : "postgres" }, "index" : { "index" : "jdbc", "type" : "jdbc" } }'
Result : {"ok":true,"_index":"_river","_type":"my_jdbc_river","_id":"_meta","_version":1}

But if I redo this with bad user or password, result is the same !!!!!!!!!!!!!!!!!

Well,
how to remove the default cluster ?
how to connect ES with PostgreSQL ? What is wrong ?
Please, please, please, please help !!!!!

Thank you very much everyone.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hello,
thank you very much for your answer.
Yes I have tried to search after creating the river but nothing.
Please look the picture with my message. I think you will understand easier
my problem.
And sorry I'm wrong : I speak about node :s

Ellande

Le vendredi 19 avril 2013 17:12:25 UTC+2, David Pilato a écrit :

Welcome!

We (frenchies) are always saying "excuse for my french". That's how
everyone know that we are french :wink:
About french question, you should be aware that there is also a french
mailing list which should help you: elastics...@googlegroups.com<javascript:>

Everything you did by now sounds ok.
Did you try to search after creating the river?
Can you see anything in logs?

Also, I don't understand what is a "Cluster" from your point of view? Are
you talking about indexes?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 avr. 2013 à 17:03, eby eurogiciel <eby.eur...@gmail.com<javascript:>>
a écrit :

Hello,
first thank you to read me !
second I'm french and my english is very bad !
third I hope you can help me. I really want to use ES !!!!

So,
I want to use ES with postgreSQL. ES and postgreSQL are on the same server
(debian).
ES is running no problem. I'm using Elasticsearch head.

It's ok but status is yellow. Normal my cluster is Unassigned
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! And there's the default
cluster (I don't mind....)

There's no modification in elasticsearch.yml.

Connection with PostgreSQL : I have done this :
https://github.com/jprante/elasticsearch-river-jdbc/wiki/Step-by-step-recipe-for-setting-up-the-river-with-PostgreSQL

curl -XPUT 'localhost:920_river/my_jdbc_river/_meta' -d '{ "type" :
"jdbc", "jdbc" : { "driver" : "org.postgresql.Driver", "url" :
"jdbc:postgresql://localhost:5432/PMS", "user" : "postgres", "password" :
"postgres" }, "index" : { "index" : "jdbc", "type" : "jdbc" } }'
Result :
{"ok":true,"_index":"_river","_type":"my_jdbc_river","_id":"_meta","_version":1}

But if I redo this with bad user or password, result is the same
!!!!!!!!!!!!!!!!!

*Well,
*

  1. how to remove the default cluster ?
  2. how to connect ES with PostgreSQL ? What is wrong ?
  3. Please, please, please, please help !!!!!

Thank you very much everyone.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Ah ah, effectivement, en français, ça va être plus simple !!!!
Surtout que pour le moment, je panne à peu près rien :s !!!

Le vendredi 19 avril 2013 17:03:11 UTC+2, eby eurogiciel a écrit :

Hello,
first thank you to read me !
second I'm french and my english is very bad !
third I hope you can help me. I really want to use ES !!!!

So,
I want to use ES with postgreSQL. ES and postgreSQL are on the same server
(debian).
ES is running no problem. I'm using Elasticsearch head.

It's ok but status is yellow. Normal my cluster is Unassigned
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! And there's the default
cluster (I don't mind....)

There's no modification in elasticsearch.yml.

Connection with PostgreSQL : I have done this :
https://github.com/jprante/elasticsearch-river-jdbc/wiki/Step-by-step-recipe-for-setting-up-the-river-with-PostgreSQL

curl -XPUT 'localhost:920_river/my_jdbc_river/_meta' -d '{ "type" :
"jdbc", "jdbc" : { "driver" : "org.postgresql.Driver", "url" :
"jdbc:postgresql://localhost:5432/PMS", "user" : "postgres", "password" :
"postgres" }, "index" : { "index" : "jdbc", "type" : "jdbc" } }'
Result :
{"ok":true,"_index":"_river","_type":"my_jdbc_river","_id":"_meta","_version":1}

But if I redo this with bad user or password, result is the same
!!!!!!!!!!!!!!!!!

*Well,
*

  1. how to remove the default cluster ?
  2. how to connect ES with PostgreSQL ? What is wrong ?
  3. Please, please, please, please help !!!!!

Thank you very much everyone.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Even with node, I don't understand what is "removing the default node"?

Removing a node from the cluster is simply "stop it".
If you need to clean an index (remove an index), just run:

curl -XDELETE http://localhost:9200/yourindexname

If you want to remove the river:

curl -XDELETE http://localhost:9200/_river/yourrivername

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 avr. 2013 à 17:24, eby eurogiciel eby.eurogiciel@gmail.com a écrit :

Hello,
thank you very much for your answer.
Yes I have tried to search after creating the river but nothing.
Please look the picture with my message. I think you will understand easier my problem.
And sorry I'm wrong : I speak about node :s

Ellande

Le vendredi 19 avril 2013 17:12:25 UTC+2, David Pilato a écrit :
Welcome!

We (frenchies) are always saying "excuse for my french". That's how everyone know that we are french :wink:
About french question, you should be aware that there is also a french mailing list which should help you: elastics...@googlegroups.com

Everything you did by now sounds ok.
Did you try to search after creating the river?
Can you see anything in logs?

Also, I don't understand what is a "Cluster" from your point of view? Are you talking about indexes?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 avr. 2013 à 17:03, eby eurogiciel eby.eur...@gmail.com a écrit :

Hello,
first thank you to read me !
second I'm french and my english is very bad !
third I hope you can help me. I really want to use ES !!!!

So,
I want to use ES with postgreSQL. ES and postgreSQL are on the same server (debian).
ES is running no problem. I'm using Elasticsearch head.

It's ok but status is yellow. Normal my cluster is Unassigned !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! And there's the default cluster (I don't mind....)

There's no modification in elasticsearch.yml.

Connection with PostgreSQL : I have done this : https://github.com/jprante/elasticsearch-river-jdbc/wiki/Step-by-step-recipe-for-setting-up-the-river-with-PostgreSQL

curl -XPUT 'localhost:920_river/my_jdbc_river/_meta' -d '{ "type" : "jdbc", "jdbc" : { "driver" : "org.postgresql.Driver", "url" : "jdbc:postgresql://localhost:5432/PMS", "user" : "postgres", "password" : "postgres" }, "index" : { "index" : "jdbc", "type" : "jdbc" } }'
Result : {"ok":true,"_index":"_river","_type":"my_jdbc_river","_id":"_meta","_version":1}

But if I redo this with bad user or password, result is the same !!!!!!!!!!!!!!!!!

Well,
how to remove the default cluster ?
how to connect ES with PostgreSQL ? What is wrong ?
Please, please, please, please help !!!!!

Thank you very much everyone.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

<ES_head.png>