Immediate logout after successful login on kibana


(Ganesh) #1

HI Team,
I'm using ELK version 6.2.1 and ES running on docker cluster. when i try to access my kibana with x-pack. its getting login and immediately get logout.

http://nemokibana.com:8080/logout?next=%2Fapp%2Fkibana%23%2Fhome%3F_g%3D()&msg=SESSION_EXPIRED

Anyone can suggest me why?


(Matt Bargar) #2

Could you try clearing your cookies and browser cache?


(Ganesh) #3

i tried to open in incognito mode also but facing same issue


(Saifeddine Hmissi) #4

Are you using multiple kibana behind a load balancer?


(Ganesh) #5

yes, i have installed kibana on 3 server and coordinate also installed on those 3 server.


(Saifeddine Hmissi) #6

Yes you have to change the sticky sessions value in your LB.


(Ganesh) #7

could you tell very specific where i have to change. what i have to change like which location and what i have to add


(Saifeddine Hmissi) #8

yes but what kind of LB you using ?

AWS LB ? Haproxy .... ??


(Ganesh) #9

Actually, by using docker its running and didnt define any LB in my coordinate node


(Matt Bargar) #10

This shouldn't be necessary, Kibana doesn't store any user state on the server.

My best guess would be that the proxy between the browser and the Kibana server is stripping headers or modifying the request in some other way.


(Ganesh) #11

can you help me out on this . what i have to modify in kibana configuration.


(Matt Bargar) #12

You mentioned you have three Kibana servers. What are you using to load balance between those servers? What is sitting between Kibana and the client's browser?


(Ganesh) #13

kibana config:

server.name: kibana
server.host: "0"
elasticsearch.url: http://lpdosput020010.phx.aexp.com:9200
elasticsearch.username: elastic
elasticsearch.password: elastic
#elasticsearch.ssl.verificationMode: none
xpack.apm.ui.enabled: true
#xpack.monitoring.ui.container.elasticsearch.enabled: true
#xpack.security.enabled: true
#server.ssl.enabled: true
#server.ssl.certificate: /usr/share/kibana/config/kibana.example.org.crt
#server.ssl.key: /usr/share/kibana/config/kibana.example.org.key

ES coordinate node:

cluster.name: "docker-cluster"
node.name: lpdosput020010.phx.aexp.com.node
node.master: false
node.data: false
node.ingest: false

#network.host: 0.0.0.0
network.bind_host: 0.0.0.0
network.publish_host: 10.3.195.17

discovery.zen.ping.unicast.hosts: ["10.3.195.14","10.3.195.38","10.3.195.41","10.3.195.43","10.3.195.37","10.3.195.17"]
discovery.zen.minimum_master_nodes: 2
#xpack.license.self_generated.type: trial
xpack.security.enabled: true
#xpack.monitoring.enabled : true
#xpack.security.http.ssl.enabled: true
#xpack.security.http.ssl.key: /usr/share/elasticsearch/config/elasticsearch/elasticsearch.key
#xpack.security.http.ssl.certificate: /usr/share/elasticsearch/config/elasticsearch/elasticsearch.crt
#xpack.security.http.ssl.client_authentication: none
#xpack.security.http.ssl.verification_mode: certificate

(Ganesh) #14

any help with below information?