Importing by hand the search / visualization / dashboard of metricbeats in Kibana 5.5.0


I am generating a lot of metricbeats that go through some intermediates systems which means the events can reach the Elasticsearch but the import of example dashboard will fail.

However, from the metricbeats archive, I was able to get the search / visualization / dashboards of the metric beats. I tried to import the Search first, like System-stats.json, after changing the index name so the file looks like this:

  "sort": [
  "hits": 0, 
  "description": "", 
  "title": "System stats", 
  "version": 1, 
  "kibanaSavedObjectMeta": {
    "searchSourceJSON": "{\"index\":\"my_index_pattern_*\",\"filter\":[],\"highlight\":{\"pre_tags\":[\"@kibana-highlighted-field@\"],\"post_tags\":[\"@/kibana-highlighted-field@\"],\"fields\":{\"*\":{}},\"require_field_match\":false,\"fragment_size\":2147483647},\"query\":{\"query_string\":{\"query\":\"metricset.module: system\",\"analyze_wildcard\":true}}}"
  "columns": [

but the import of this file fails with:

Saved Objects: Saved objects file format is invalid and cannot be imported.

Does anyone can help me?

Import of dashboards doesn't need to be done from the machines where metricbeat is collecting metrics, you can import the dashboards from other machine that can reach Elasticsearch.

Well, it's complicated. I'm using an ES 5.5.0 but I collect metrics from a source with metricbeats 6.3.2. So the metricbeats 5.5.0 dashboards are not compatible. I also tried to use metricbeats 6.3.2 to setup the dashboard "by the Kibana API" however it requires nonetheless Elasticsearch API to do the setup. If I provide a fake ES so the metricbeats setup proceed, it seems to not work, while outputing a normal and ending setup messages (but no line about dashboard installation work).

With "by the Kibana API" do you mean with metricbeat setup --dashboards?

Well, I just made a setup without --dashboard. I found this that looks a lot like my issue, but I don't understand in fine which of the solution was the real one!

Please try to run the setup of dashboards with the --dashboard flag.

If you are also having these errors about fields, what this post mentions is to try to reload the index fields list.

Retried, same probelm, updated fileds, same problem. In the dashboard I have visualizations that are filled with data, and other they are not. In the spy window of Kibana we see that some visualizations have empty body in the requests, like in the problem I linked in my previous message.

With what dashboards are you having problems, and what version of Kibana are you using?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.