Importing prebuilt kibana dashboards: "0 objects imported"

Hey there :slight_smile:

I am experiencing issues importing prebuilt dashboards in kibana from , i follow the installation procedure but i dont get new dashboards available in "saved objects".

Does anyone have any exp with this ?

Many thanks!

Can you elaborate on which particular dashboard you are trying, and which version of ES/Kibana you are running. I successfully imported the kibana-alerting-enhancement dashboard into 7.15. I downloaded and extracted the .zip, and imported the .ndjson file.

1 Like

Morning :slight_smile:

Ok so my Elastic is 7.12.1. I tried to import:

  • threat hunting
  • cloudflare
  • alerting enhancement
  • machine learning

All of them were downloaded, unzipped and imported from their "export.ndjson" file.

The elastic logo spins for a while, like for a min or so then there a message saying "0 objects imported".

Wonder whether it s due to the ELK version i am running.


A couple of those do appear to require a newer version. But the enhanced alerting dashboard worked for me on 7.12.1. Perhaps retry while running the network inspector on your browser and watch for errors.
Do you have a WAF that might be interfering?

Those dashboards are made by myself. Can you tell me a little more about the issue you are facing?
Do you run Kibana in premise or in the cloud?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.