$ in Top N graph of TSVB

I have a run time field "Abs Delta Value" which has format as $0,0.[000]. The $ sign is showing on all charts in lens and elsewhere except on TSVB.
In the "Top N" chart under TSVB, it is only showing the number without the $ and I don't find an option to add the $ here. How can we show the $ sign here? Thanks

Hi @behappy_alwayz0401 ,

I assume you've set a field formatter which is not reflecting in a TSVB.
Are you using a Math aggregation by chance to compute the Abs or Delta for the field?

In case you are using the Math aggregation the editor will ignore the field formatter as the Math aggregation is generic and might mix different field types. But there's a workaround for that, which is setting the format at the TSVB visualization level as follow:

In the pic above I've set a Custom formatter, but other ready-to-use formatters (as Bytes/Numbers/etc...) are available too and customizable.

1 Like

This worked, thanks a lot..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.