Index.max_result_window increase limit- not updating?


(brandon plasters) #1

hello, i'm trying to update my index.max_result_window using put to here with the following body:

http://<my_url>:9200/.kibana/_settings PUT { "index" : { "max_result_window" : 2147483647 } }

it returns: {acknowledged : true}

but when i try and run my command i still get this error when using the api:

Result window is too large, from + size must be less than or equal to: [10000] but was [10004]. See the scroll api for a more efficient way to request large data sets. This limit can be set by changing the [index.max_result_window] index level parameter.

as if my updated settings did not change anything.

I also restarted the ELK stack with no luck.

Any Ideas? i've Googled everywhere and it seems like the settings update should've worked as expected?

My version of Kibana is:

Version 4.3.1
Build 9517
Commit SHA d6e412d

any help would be appreciated. thanks,

Brandon


(Leforthomas) #2

Have you managed to solve this problem? I have the same and no idea what else to try.

I tried to use scrolling first but it doesn't work either... but that's probably for a different question!


(system) #3