Index.routing.allocation.include not working


(Mohit Anchlia) #1

I have 2 nodes and I created a new index and given this routing rule. Node
1 has "node.group1 : group1" set in yaml file and Node 2 has "node.group1 :
group2" set in the file. However, when I write data it still is getting
writen to both the nodes. I just want it to go to only Node 2. Can I get
some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

Did you restart the nodes after setting that parameter in the config file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.com wrote:

I have 2 nodes and I created a new index and given this routing rule. Node
1 has "node.group1 : group1" set in yaml file and Node 2 has "node.group1 :
group2" set in the file. However, when I write data it still is getting
writen to both the nodes. I just want it to go to only Node 2. Can I get
some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mohit Anchlia) #3

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom markw@campaignmonitor.comwrote:

Did you restart the nodes after setting that parameter in the config file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.com wrote:

I have 2 nodes and I created a new index and given this routing rule.
Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mohit Anchlia) #4

I am still facing this issue and looking for suggestions.

On Thu, Nov 21, 2013 at 3:00 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom markw@campaignmonitor.comwrote:

Did you restart the nodes after setting that parameter in the config file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.com wrote:

I have 2 nodes and I created a new index and given this routing rule.
Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #5

Hey,

if you could include a fully fledged example of what you did, including
your configuration changes and all the curl commands you executed, this
would help people to debug your problem, see
http://www.elasticsearch.org/help

Thanks!

--Alex

On Fri, Nov 22, 2013 at 8:47 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am still facing this issue and looking for suggestions.

On Thu, Nov 21, 2013 at 3:00 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom markw@campaignmonitor.comwrote:

Did you restart the nodes after setting that parameter in the config
file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.com wrote:

I have 2 nodes and I created a new index and given this routing rule.
Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mohit Anchlia) #6

I added to the yaml file for node .86. I only want this index to be stored
on .86 node but it also is getting stored in .242 node. I have 2 nodes so
far.

node.group1: group2

Then I added this setting:

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'
Head shows this for 2 nodes:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}
{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Fri, Nov 22, 2013 at 10:10 PM, Alexander Reelsen alr@spinscale.dewrote:

Hey,

if you could include a fully fledged example of what you did, including
your configuration changes and all the curl commands you executed, this
would help people to debug your problem, see
http://www.elasticsearch.org/help

Thanks!

--Alex

On Fri, Nov 22, 2013 at 8:47 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am still facing this issue and looking for suggestions.

On Thu, Nov 21, 2013 at 3:00 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom markw@campaignmonitor.comwrote:

Did you restart the nodes after setting that parameter in the config
file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.comwrote:

I have 2 nodes and I created a new index and given this routing rule.
Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mohit Anchlia) #7

I am still looking for suggestions.

On Sun, Nov 24, 2013 at 7:01 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I added to the yaml file for node .86. I only want this index to be stored
on .86 node but it also is getting stored in .242 node. I have 2 nodes so
far.

node.group1: group2

Then I added this setting:

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'
Head shows this for 2 nodes:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}
{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Fri, Nov 22, 2013 at 10:10 PM, Alexander Reelsen alr@spinscale.dewrote:

Hey,

if you could include a fully fledged example of what you did, including
your configuration changes and all the curl commands you executed, this
would help people to debug your problem, see
http://www.elasticsearch.org/help

Thanks!

--Alex

On Fri, Nov 22, 2013 at 8:47 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am still facing this issue and looking for suggestions.

On Thu, Nov 21, 2013 at 3:00 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom <markw@campaignmonitor.com

wrote:

Did you restart the nodes after setting that parameter in the config
file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia mohitanchlia@gmail.comwrote:

I have 2 nodes and I created a new index and given this routing rule.
Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWozXDEPH0f5VvCkc0icSwtV-r30NGR8L5ha8LedsduEPw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(hrishikesh prabhune) #8

Wow this is really weird . Actually I was also facing the same problem some
time back. But it got solved by playing around with ira.exclude.* and
ira.require.* setting. Here are some things you can try. I can't guarantee
that it will work.
I think you should just have index.routing.allocation.exclude.group1:
group1 in the settings of the test4 index. Also see if you can set the
value of the node attribute (key) to something else than group1.

Also, are you using any cluster routing awareness setting in your
elasticsearch.yml file ?
Let me know how it goes!

Cheers!

On Wednesday, November 27, 2013 4:01:02 PM UTC-8, Mo wrote:

I am still looking for suggestions.

On Sun, Nov 24, 2013 at 7:01 PM, Mohit Anchlia <mohita...@gmail.com<javascript:>

wrote:

I added to the yaml file for node .86. I only want this index to be
stored on .86 node but it also is getting stored in .242 node. I have 2
nodes so far.

node.group1: group2

Then I added this setting:

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'
Head shows this for 2 nodes:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}
{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Fri, Nov 22, 2013 at 10:10 PM, Alexander Reelsen <a...@spinscale.de<javascript:>

wrote:

Hey,

if you could include a fully fledged example of what you did, including
your configuration changes and all the curl commands you executed, this
would help people to debug your problem, see
http://www.elasticsearch.org/help

Thanks!

--Alex

On Fri, Nov 22, 2013 at 8:47 PM, Mohit Anchlia <mohita...@gmail.com<javascript:>

wrote:

I am still facing this issue and looking for suggestions.

On Thu, Nov 21, 2013 at 3:00 PM, Mohit Anchlia <mohita...@gmail.com<javascript:>

wrote:

yes. And head shows this as well:

{

  • name: 10.80.140.242
  • transport_address: inet[/10.80.140.242:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.242:9200]
  • attributes: {
    • group1: group1
      }

}
{

  • name: 10.80.140.86
  • transport_address: inet[/10.80.140.86:9300]
  • version: 0.90.6
  • http_address: inet[/10.80.140.86:9200]
  • attributes: {
    • group1: group2
      }

}

{

  • state: open
  • settings: {
    • index.number_of_replicas: 1
    • index.number_of_shards: 5
    • index.version.created: 900699
    • index.uuid: Bqd1gRznTl6U5IUFDevLqA
    • index.routing.allocation.include.group1: group2
    • index.routing.allocation.exclude.group1: group1
      }
  • mappings: { }
  • aliases: [ ]

}

On Thu, Nov 21, 2013 at 2:47 PM, Mark Walkom <
ma...@campaignmonitor.com <javascript:>> wrote:

Did you restart the nodes after setting that parameter in the config
file?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 22 November 2013 09:46, Mohit Anchlia <mohita...@gmail.com<javascript:>

wrote:

I have 2 nodes and I created a new index and given this routing
rule. Node 1 has "node.group1 : group1" set in yaml file and Node 2 has
"node.group1 : group2" set in the file. However, when I write data it still
is getting writen to both the nodes. I just want it to go to only Node 2.
Can I get some suggestions on why this might be happening?

curl -XPUT 10.80.140.86:9200/test4/_settings -d '{
"index.routing.allocation.include.group1" : "group2",
"index.routing.allocation.exclude.group1" : "group1"
}'

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/548b5cd5-f270-4482-8a74-c81d4df62c39%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #9