Setting index.routing.allocation.include.node failure


(Ryan Bellows) #1

Hi all,
I've got a 5 node elasticsearch cluster that has 3 machines with a
"node.storage: ssd_fast" and 2 with "node.storage: sata_slow" attributes.
I'd like to write today's index (this is being used for logstash) to the
ssd machines, and then use the slow ones for archiving shards.

Here's the error I"m getting when I try to change the index routing (for
all existing indexes):

curl -XPUT es3:9200/_settings -d '{
"index" : {
"index.routing.allocation.include.node.storage" : "ssd_fast"
}
}'

{"error":"RemoteTransportException[[es3][inet[/10.123.123.103:9300]][indices/settings/update]];
nested: ElasticsearchIllegalArgumentException[Can't update non dynamic
settings[[index.index.routing.allocation.include.node.storage]] for open
indices[[logstash-sfo1-2014.04.09, logstash-sfo1-2014.04.08, kibana-int]]];
","status":400}k

Any pointers appreciated, thanks.

-Ryan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

You need to put that into the elasticsearch.yml and then restart each node.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 April 2014 10:46, Ryan Bellows rtb@weebly.com wrote:

Hi all,
I've got a 5 node elasticsearch cluster that has 3 machines with a
"node.storage: ssd_fast" and 2 with "node.storage: sata_slow" attributes.
I'd like to write today's index (this is being used for logstash) to the
ssd machines, and then use the slow ones for archiving shards.

Here's the error I"m getting when I try to change the index routing (for
all existing indexes):

curl -XPUT es3:9200/_settings -d '{
"index" : {
"index.routing.allocation.include.node.storage" : "ssd_fast"
}
}'

{"error":"RemoteTransportException[[es3][inet[/10.123.123.103:9300]][indices/settings/update]];
nested: ElasticsearchIllegalArgumentException[Can't update non dynamic
settings[[index.index.routing.allocation.include.node.storage]] for open
indices[[logstash-sfo1-2014.04.09, logstash-sfo1-2014.04.08, kibana-int]]];
","status":400}k

Any pointers appreciated, thanks.

-Ryan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624b4jV5LqDUkBYUeBz9_TOvOG_9uxY8MigOOv1tRCxjfFA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ryan Bellows) #3

Ah, to be clear, those attributes are already in the elasticsearch.yml
files on all 5 servers.

On Tuesday, April 8, 2014 5:53:43 PM UTC-7, Mark Walkom wrote:

You need to put that into the elasticsearch.yml and then restart each node.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 9 April 2014 10:46, Ryan Bellows <r...@weebly.com <javascript:>> wrote:

Hi all,
I've got a 5 node elasticsearch cluster that has 3 machines with a
"node.storage: ssd_fast" and 2 with "node.storage: sata_slow" attributes.
I'd like to write today's index (this is being used for logstash) to the
ssd machines, and then use the slow ones for archiving shards.

Here's the error I"m getting when I try to change the index routing (for
all existing indexes):

curl -XPUT es3:9200/_settings -d '{
"index" : {
"index.routing.allocation.include.node.storage" : "ssd_fast"
}
}'

{"error":"RemoteTransportException[[es3][inet[/10.123.123.103:9300]][indices/settings/update]];
nested: ElasticsearchIllegalArgumentException[Can't update non dynamic
settings[[index.index.routing.allocation.include.node.storage]] for open
indices[[logstash-sfo1-2014.04.09, logstash-sfo1-2014.04.08, kibana-int]]];
","status":400}k

Any pointers appreciated, thanks.

-Ryan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ca9f34ae-5fa1-4771-b4e7-daf272c1c024%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #4

Ok, but you can't dynamically update them, you can only ever define them in
the .yml and then restart the service for the value to be changed.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 April 2014 10:59, Ryan Bellows rtb@weebly.com wrote:

Ah, to be clear, those attributes are already in the elasticsearch.yml
files on all 5 servers.

On Tuesday, April 8, 2014 5:53:43 PM UTC-7, Mark Walkom wrote:

You need to put that into the elasticsearch.yml and then restart each
node.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 9 April 2014 10:46, Ryan Bellows r...@weebly.com wrote:

Hi all,
I've got a 5 node elasticsearch cluster that has 3 machines with a
"node.storage: ssd_fast" and 2 with "node.storage: sata_slow" attributes.
I'd like to write today's index (this is being used for logstash) to the
ssd machines, and then use the slow ones for archiving shards.

Here's the error I"m getting when I try to change the index routing (for
all existing indexes):

curl -XPUT es3:9200/_settings -d '{
"index" : {
"index.routing.allocation.include.node.storage" : "ssd_fast"
}
}'

{"error":"RemoteTransportException[[es3][inet[/10.123.123.103:9300]][indices/settings/update]];
nested: ElasticsearchIllegalArgumentException[Can't update non dynamic
settings[[index.index.routing.allocation.include.node.storage]] for
open indices[[logstash-sfo1-2014.04.09, logstash-sfo1-2014.04.08,
kibana-int]]]; ","status":400}k

Any pointers appreciated, thanks.

-Ryan

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ca9f34ae-5fa1-4771-b4e7-daf272c1c024%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ca9f34ae-5fa1-4771-b4e7-daf272c1c024%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624Yr_jh84-poiMqFEiVC0uzX_ausDmXW7DPuBnhmXkfdqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ryan Bellows) #5

The nodes all have that value in their elasticsearch.yml files, and have
been restarted since then.

I'm getting the error trying to update indexes to store their shards only
on those nodes with the appropriate node.storage value. I was under the
impression that was a basic way to do shard routing, am I mistaken?

-R

On Tuesday, April 8, 2014 6:01:24 PM UTC-7, Mark Walkom wrote:

Ok, but you can't dynamically update them, you can only ever define them
in the .yml and then restart the service for the value to be changed.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 9 April 2014 10:59, Ryan Bellows <r...@weebly.com <javascript:>> wrote:

Ah, to be clear, those attributes are already in the elasticsearch.yml
files on all 5 servers.

On Tuesday, April 8, 2014 5:53:43 PM UTC-7, Mark Walkom wrote:

You need to put that into the elasticsearch.yml and then restart each
node.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 9 April 2014 10:46, Ryan Bellows r...@weebly.com wrote:

Hi all,
I've got a 5 node elasticsearch cluster that has 3 machines with a
"node.storage: ssd_fast" and 2 with "node.storage: sata_slow" attributes.
I'd like to write today's index (this is being used for logstash) to the
ssd machines, and then use the slow ones for archiving shards.

Here's the error I"m getting when I try to change the index routing
(for all existing indexes):

curl -XPUT es3:9200/_settings -d '{
"index" : {
"index.routing.allocation.include.node.storage" : "ssd_fast"
}
}'

{"error":"RemoteTransportException[[es3][inet[/10.123.123.103:9300]][indices/settings/update]];
nested: ElasticsearchIllegalArgumentException[Can't update non dynamic
settings[[index.index.routing.allocation.include.node.storage]] for
open indices[[logstash-sfo1-2014.04.09, logstash-sfo1-2014.04.08,
kibana-int]]]; ","status":400}k

Any pointers appreciated, thanks.

-Ryan

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3d3d6edd-6b57-4c0c-8e6d-dd98f8aa84dc%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ca9f34ae-5fa1-4771-b4e7-daf272c1c024%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ca9f34ae-5fa1-4771-b4e7-daf272c1c024%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a56036fa-71ce-4dca-ad6b-33027f834d84%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Oleg Andreyev) #6

I'm definitely late, but your query is wrong. Today I've faced exact the same issue.
It should be:

curl -XPUT "http://localhost:9200/test/_settings" -d'
{
  "index.routing.allocation.include.indexing": false
}'

or

curl -XPUT "http://dev-es2.i.intexsys.lv:9200/opcart_opticsplanet_test_2016-10-24-155301/_settings" -d'
{
  "index": {
    "routing.allocation.include.indexing": false
  }
}'

but not

curl -XPUT "http://dev-es2.i.intexsys.lv:9200/opcart_opticsplanet_test_2016-10-24-155301/_settings" -d'
{
  "index": {
    "index.routing.allocation.include.indexing": false
  }
}'

(system) #7