Indicie refreshing problem

We got an Index with around 8K fields and everytime I refresh Kibana it resets the Indicie fields to 5.
Is there a maximum of fields that Kibana can hold or handle with ? Or is this just an storage problem ?

Im working on Kibana 5.0 . Are there bugfixes for this issue in later versions?

@magerRV are you only seeing 5 fields when refreshing the fields?

Are you using Chrome to refresh the fields list? There's an undocumented maximum XMLHttpRequest response size that you might be hitting in Chrome, that I've seen cause this behavior before. Do you happen to have access to a modern build of Safari, and could you try refreshing the fields list using Safari?

@Brandon_Kobel first I see 5 fields after re-indexing I get around around 8K fields. But after creating e.g. a scripted field and refreshing Kibana it goes back to 5 fields.

we have 5 indicies (4 of them between 1500 und 2500 fields) but the largest with around 8K doesnt seem to be safed after refreshing Kibana. I think it could come with an cashing or space Problem ?!

I'm using Firefox for Kibana. Do you think its a browser based problem ?

Actually it doesnt matter if I creat anything. After refresh my Kibana tab it goes back to 5 fields all the time. (Only in this case, the other 4 indicies dont have any problem)

@magerRV when hitting the maximum response for a XMLHttpRequest in Firefox, I've generally seen an error logged in the browser console. Would you mind checking Firefox's console to see if any error is logged when refreshing the fields? To open the Firefox console, if you right-click on the page and then select "Inspect Element" , and then open the "Console" tab highlighted below:

Error: Request to Elasticsearch failed: "Bad Request"

thats what I get by re-indexing

mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create commons.bundle.js:45:21299
window.controllers sollte nicht mehr verwendet werden. Verwenden Sie es nicht für die Browser-Erkennung.
("window.controllers souldnt be used. Dont use it for browser detection")
setting active api to [es_5_0] kibana.bundle.js:114:17926
loading default index pattern commons.bundle.js:55
Index Patterns: index pattern set to .kibana commons.bundle.js:2:5796
complete in 523.64ms

thats what I get after refreshing Kibana

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.