Installing topbeats on a windows machine


(aviv ratzon) #1

Hi,
I'm trying to install topbeats, but when I run the command in power shell it doesn't ouput anything and when trying to start the service it says it can't find it.
The only thing the installation does is replace the content of the ps1 file with a table like this:

Handles  NPM(K)    PM(K)      WS(K) VM(M)   CPU(s)     Id ProcessName                                                  
-------  ------    -----      ----- -----   ------     -- -----------                                                  
    134      17    14600       8068    92     0.06   4040 amswmagt                                                     
     76       8     1576       4540    43     0.03   1556 armsvc                                                       
    128      10    15876      15948    52            6804 audiodg                                                      
    430      35    19900      40564   217     1.45   5188 Babylon                                                      
    677      48    13064      22444   146     1.90   1644 CAF                                                          
    412      20     5104      10544    66     0.22   1584 cam                                                          
    360      31     8808      15232   118     2.07   1700 casplitegent                                                 
    165      18    16020      20940    96     0.53   3568 ccnfAgent        
............................. 

I'm pretty clueless as to what the problem is...
thanks!


(Steffen Siering) #2

where did you install topbeat into? How do you start it? Can you try to run with -e -d '*' to generate some debug output on console?


(Rafael) #3

Hi,
I did the same as Aviv, and proceeded opening the file in a text editor.
The issue may be permission, as you run powershell, you are usually not running with Admin rights, and the window with the error message close at the end of the script leaving everyone guessing what happened.
I opened powershell with admin rights, pasted the install file content there, and realised the $workdir assignment was cutting the last directory out during Split-Path.
That problem prevents the service from starting, since it can't find the executable or config files.

I repeated the last directory name twice (e.g. $workdir = Split-Path c:\topbeat\topbeat\ when files were at c:\topbeat) on the $workdir assignment, created the service, and it worked, I now have the service installed and running.
That's on Windows 10.

By the way, I left it running on a tight memory system, and it seems the beta4 has some memory leak going on. The process goes from 15Mb to 32Mb+ in minutes.
How much ram memory topbeat require?

cheers,
Rafael


(system) #4