Internal Server Error after trying to save a Query

Hello together,

we are using Kibana with version 7.8.1, unfortunately I am completely noob on Kibana so would really appricate any help. Basically, as soon as I try to "save search" I get internal server errors....

If you need other logs fo Analysis, feel free to mention which ones!

Logs:

Nov  8 11:20:52  kibana[15043]: {"type":"response","@timestamp":"2022-11-08T10:20:52Z","tags":[],"pid":15043,"method":"get","statusCode":200,"req":{"url":"/api/saved_objects/_find?fields=title&per_page=10&search=%22hshsh%22&search_fields=title&type=search","method":"get","headers":{"host":"127.0.0.1:5601","connection":"keep-alive","sec-ch-ua":"\"Google Chrome\";v=\"107\", \"Chromium\";v=\"107\", \"Not=A?Brand\";v=\"24\"","content-type":"application/json","kbn-version":"7.8.1","sec-ch-ua-mobile":"?0","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/107.0.0.0 Safari/537.36","sec-ch-ua-platform":"\"Windows\"","accept":"*/*","sec-fetch-site":"same-origin","sec-fetch-mode":"cors","sec-fetch-dest":"empty","referer":"http://127.0.0.1:5601/app/kibana","accept-encoding":"gzip, deflate, br","accept-language":"de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7"},"remoteAddress":"172.20.1.160","userAgent":"172.20.1.160","referer":"http://127.0.0.1:5601/app/kibana"},"res":{"statusCode":200,"responseTime":41,"contentLength":9},"message":"GET /api/saved_objects/_find?fields=title&per_page=10&search=%22hshsh%22&search_fields=title&type=search 200 41ms - 9.0B"}

Nov  8 11:20:52  kibana[15043]: {"type":"error","@timestamp":"2022-11-08T10:20:52Z","tags":[],"pid":15043,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n    at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:132:19)\n    at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:86:19)\n    at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:81:17)\n    at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:162:34)\n    at process._tickCallback (internal/process/next_tick.js:68:7)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"?overwrite=true","query":{"overwrite":"true"},"pathname":"/api/saved_objects/search","path":"/api/saved_objects/search?overwrite=true","href":"/api/saved_objects/search?overwrite=true"},"message":"Internal Server Error"}

Nov  8 11:20:52  kibana[15043]: {"type":"response","@timestamp":"2022-11-08T10:20:52Z","tags":[],"pid":15043,"method":"post","statusCode":500,"req":{"url":"/api/saved_objects/search?overwrite=true","method":"post","headers":{"host":"127.0.0.1:5601","connection":"keep-alive","content-length":"499","sec-ch-ua":"\"Google Chrome\";v=\"107\", \"Chromium\";v=\"107\", \"Not=A?Brand\";v=\"24\"","content-type":"application/json","kbn-version":"7.8.1","sec-ch-ua-mobile":"?0","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/107.0.0.0 Safari/537.36","sec-ch-ua-platform":"\"Windows\"","accept":"*/*","origin":"http://127.0.0.1:5601","sec-fetch-site":"same-origin","sec-fetch-mode":"cors","sec-fetch-dest":"empty","referer":"http://127.0.0.1:5601/app/kibana","accept-encoding":"gzip, deflate, br","accept-language":"de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7"},"remoteAddress":"172.20.1.160","userAgent":"172.20.1.160","referer":"http://127.0.0.1:5601/app/kibana"},"res":{"statusCode":500,"responseTime":101,"contentLength":9},"message":"POST /api/saved_objects/search?overwrite=true 500 101ms - 9.0B"}

Thank you in advance!
Yours sincerely,

LightX

Hi,

Which version of Elasticsearch are you using with this?
Any chance you could upgrade into a latest version v7.17.x version?

Cheers

Thank you for the quick recap.
The solution was to set the actual system indexed on reading and writing in the settings and make space for the index to write.