Issue starting Elasticsearch on windows


(Ij888) #1

elasticsearch cmd closes rapidly on double-clicking elasticsearch.bat. How can I please stop this and make it work as outlined in the elasticsearch docs?


(Christian Dahlqvist) #2

Please provide additional details. Is any error shown? Is there anything in the logs? What does your configuration look like?


(Ij888) #3

Hi thanks for responding. There is no error shown, the cmd window flashes for about a third of a second and closes


(Ij888) #4

Windows10, Java 1.8 u71, Elasticsearch 2.1.1


(Mark Walkom) #5

You should really call the ES batch file from within a CMD window, not double clicking it.


(Ij888) #6

I did try to call ES from cmd but got the screenshot above! Made certain my Java_Home path set correctly but issue persists


(Dan Burns) #7

Having the same issue, and Elasticsearch worked a few days ago, but now I'm getting the same above error.


(Mark Walkom) #8

Try .\elasticsearch.bat, or ./elasticsearch.bat, I dunno which works with Windows.


(Ij888) #9

Does files with the .bat filename need be run in cmd? I would think one just runs elasticsearch provided you are in the elasticsearch bin directory.

###update
Any updates, please??

###LatestUpdate
Completely cleared and reset my environment variables. On downloading and running Elasticsearch 2.2.0 everything ran beautifully, so I compared the .bat files with that of Elasticsearch 2.1.1's to see if there was any differences- there was. But on running the ES.2.1.1 files, it worked.
I suppose my environment variables needed a bit of housekeeping


(system) #10